GNU Debugger bis 8.0 DWARF Section Negative Length Denial of Service

CVSS Meta Temp ScoreAktueller Exploitpreis (≈)CTI Interest Score
4.4$0-$5k0.00

In GNU Debugger bis 8.0 wurde eine Schwachstelle ausgemacht. Sie wurde als problematisch eingestuft. Das betrifft ein unbekannter Codeblock der Komponente DWARF Section Handler. Durch Beeinflussen durch Negative Length kann eine Denial of Service-Schwachstelle ausgenutzt werden. CWE definiert das Problem als CWE-399. Dies wirkt sich aus auf die Verfügbarkeit. CVE fasst zusammen:

GNU Debugger (GDB) 8.0 and earlier fails to detect a negative length field in a DWARF section. A malformed section in an ELF binary or a core file can cause GDB to repeatedly allocate memory until a process limit is reached. This can, for example, impede efforts to analyze malware with GDB.

Am 15.06.2017 wurde das Problem entdeckt. Die Schwachstelle wurde am 21.06.2017 als Bug 21600 in Form eines nicht definierten Bug Reports (Bugzilla) an die Öffentlichkeit getragen. Auf sourceware.org kann das Advisory eingesehen werden. Eine eindeutige Identifikation der Schwachstelle wird seit dem 21.06.2017 mit CVE-2017-9778 vorgenommen. Die Umsetzung des Angriffs kann dabei über das Netzwerk erfolgen. Um eine Ausnutzung durchzusetzen, muss keine spezifische Authentisierung umgesetzt werden. Es wird vorausgesetzt, dass das Opfer eine spezifische Handlung vornimmt. Nicht vorhanden sind sowohl technische Details als auch ein Exploit zur Schwachstelle.

Insgesamt 6 Tage schien es sich um eine nicht veröffentlichte Zero-Day Schwachstelle gehandelt zu haben. Während dieser Zeit erzielte er wohl etwa $0-$5k auf dem Schwarzmarkt.

Es sind keine Informationen bezüglich Gegenmassnahmen bekannt. Der Einsatz eines alternativen Produkts bietet sich im Zweifelsfall an.

Produktinfo

Hersteller

Name

CPE 2.3info

CPE 2.2info

CVSSv3info

VulDB Meta Base Score: 4.4
VulDB Meta Temp Score: 4.4

VulDB Base Score: 3.3
VulDB Temp Score: 3.3
VulDB Vector: 🔍
VulDB Zuverlässigkeit: 🔍

NVD Base Score: 5.5
NVD Vector: 🔍

CVSSv2info

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VektorKomplexitätAuthentisierungVertraulichkeitIntegritätVerfügbarkeit
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Zuverlässigkeit: 🔍

NVD Base Score: 🔍

Exploitinginfo

Klasse: Denial of Service
CWE: CWE-399
ATT&CK: Unbekannt

Lokal: Nein
Remote: Ja

Verfügbarkeit: 🔍
Status: Nicht definiert

EPSS Score: 🔍
EPSS Percentile: 🔍

Preisentwicklung: 🔍
Aktuelle Preisschätzung: 🔍

0-Dayfreischaltenfreischaltenfreischaltenfreischalten
Heutefreischaltenfreischaltenfreischaltenfreischalten

Threat Intelligenceinfo

Interesse: 🔍
Aktive Akteure: 🔍
Aktive APT Gruppen: 🔍

Gegenmassnahmeninfo

Empfehlung: keine Massnahme bekannt
Status: 🔍

0-Day Time: 🔍

Timelineinfo

15.06.2017 🔍
21.06.2017 +6 Tage 🔍
21.06.2017 +0 Tage 🔍
21.06.2017 +0 Tage 🔍
21.06.2017 +0 Tage 🔍
23.06.2017 +2 Tage 🔍
19.10.2019 +848 Tage 🔍

Quelleninfo

Hersteller: gnu.org

Advisory: Bug 21600
Status: Nicht definiert
Bestätigung: 🔍

CVE: CVE-2017-9778 (🔍)
SecurityFocus: 99244 - GNU Debugger (GDB) CVE-2017-9778 Denial of Service Vulnerability

Eintraginfo

Erstellt: 21.06.2017 14:35
Aktualisierung: 19.10.2019 12:37
Anpassungen: (4) vulnerability_discoverydate advisory_confirm_url source_securityfocus_date source_securityfocus_class
Komplett: 🔍

Kommentare

Bisher keine Kommentare. Sprachen: de + en.

Bitte loggen Sie sich ein, um kommentieren zu können.

Do you want to use VulDB in your project?

Use the official API to access entries easily!