Connman bis 1.40 TCP Server Reply Information Disclosure

CVSS Meta Temp ScoreAktueller Exploitpreis (≈)CTI Interest Score
3.4$0-$5k0.00

In Connman bis 1.40 wurde eine problematische Schwachstelle entdeckt. Es geht um unbekannter Code der Komponente TCP Server Reply Handler. Mittels dem Manipulieren mit einer unbekannten Eingabe kann eine Information Disclosure-Schwachstelle ausgenutzt werden. CWE definiert das Problem als CWE-125. Auswirkungen hat dies auf die Vertraulichkeit. Die Zusammenfassung von CVE lautet:

An issue was discovered in the DNS proxy in Connman through 1.40. The TCP server reply implementation lacks a check for the presence of sufficient Header Data, leading to an out-of-bounds read.

Die Schwachstelle wurde am 28.01.2022 öffentlich gemacht. Bereitgestellt wird das Advisory unter git.kernel.org. Die Verwundbarkeit wird seit dem 11.01.2022 als CVE-2022-23096 geführt. Sie ist leicht auszunutzen. Der Angriff kann im lokalen Netzwerk angegangen werden. Um eine Ausnutzung durchzusetzen, muss eine einfache Authentisierung umgesetzt werden. Technische Details oder ein Exploit zur Schwachstelle sind nicht verfügbar.

Die Schwachstelle lässt sich durch das Einspielen eines Patches lösen. Dieser kann von git.kernel.org bezogen werden.

Produktinfoanpassen

Name

CPE 2.3infoanpassen

CPE 2.2infoanpassen

CVSSv3infoanpassen

VulDB Meta Base Score: 3.5
VulDB Meta Temp Score: 3.4

VulDB Base Score: 3.5
VulDB Temp Score: 3.4
VulDB Vector: 🔒
VulDB Zuverlässigkeit: 🔍

CVSSv2infoanpassen

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VektorKomplexitätAuthentisierungVertraulichkeitIntegritätVerfügbarkeit
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten

VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Zuverlässigkeit: 🔍

Exploitinginfoanpassen

Klasse: Information Disclosure
CWE: CWE-125
ATT&CK: Unbekannt

Lokal: Nein
Remote: Teilweise

Verfügbarkeit: 🔒
Status: Nicht definiert
Preisentwicklung: 🔍
Aktuelle Preisschätzung: 🔒

0-Dayfreischaltenfreischaltenfreischaltenfreischalten
Heutefreischaltenfreischaltenfreischaltenfreischalten

Threat Intelligenceinfoanpassen

Interesse: 🔍
Aktive Akteure: 🔍
Aktive APT Gruppen: 🔍

Gegenmassnahmeninfoanpassen

Empfehlung: Patch
Status: 🔍

0-Day Time: 🔒

Patch: git.kernel.org

Timelineinfoanpassen

11.01.2022 CVE zugewiesen
28.01.2022 +17 Tage Advisory veröffentlicht
28.01.2022 +0 Tage VulDB Eintrag erstellt
30.01.2022 +2 Tage VulDB letzte Aktualisierung

Quelleninfoanpassen

Advisory: git.kernel.org
Status: Bestätigt

CVE: CVE-2022-23096 (🔒)

Eintraginfoanpassen

Erstellt: 28.01.2022 19:00
Aktualisierung: 30.01.2022 13:37
Anpassungen: (1) source_cve_nvd_summary
Komplett: 🔍

Kommentare

Bisher keine Kommentare. Sprachen: de + en.

Bitte loggen Sie sich ein, um kommentieren zu können.

Interested in the pricing of exploits?

See the underground prices here!