Connman bis 1.40 DNS Proxy forward_dns_reply Information Disclosure

CVSS Meta Temp ScoreAktueller Exploitpreis (≈)CTI Interest Score
3.4$0-$5k0.00

Eine problematische Schwachstelle wurde in Connman bis 1.40 entdeckt. Es geht hierbei um die Funktion forward_dns_reply der Komponente DNS Proxy. Mittels Manipulieren mit einer unbekannten Eingabe kann eine Information Disclosure-Schwachstelle ausgenutzt werden. Klassifiziert wurde die Schwachstelle durch CWE als CWE-125. Auswirkungen sind zu beobachten für die Vertraulichkeit. CVE fasst zusammen:

An issue was discovered in the DNS proxy in Connman through 1.40. forward_dns_reply mishandles a strnlen call, leading to an out-of-bounds read.

Die Schwachstelle wurde am 28.01.2022 veröffentlicht. Auf git.kernel.org kann das Advisory eingesehen werden. Die Identifikation der Schwachstelle findet seit dem 11.01.2022 als CVE-2022-23097 statt. Der Angriff kann im lokalen Netzwerk passieren. Das Angehen einer einfachen Authentisierung ist erforderlich, um eine Ausnutzung anzugehen. Zur Schwachstelle sind technische Details bekannt, ein verfügbarer Exploit jedoch nicht.

Die Schwachstelle lässt sich durch das Einspielen eines Patches beheben. Dieser kann von git.kernel.org bezogen werden.

Produktinfoanpassen

Name

CPE 2.3infoanpassen

CPE 2.2infoanpassen

CVSSv3infoanpassen

VulDB Meta Base Score: 3.5
VulDB Meta Temp Score: 3.4

VulDB Base Score: 3.5
VulDB Temp Score: 3.4
VulDB Vector: 🔒
VulDB Zuverlässigkeit: 🔍

CVSSv2infoanpassen

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VektorKomplexitätAuthentisierungVertraulichkeitIntegritätVerfügbarkeit
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten

VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Zuverlässigkeit: 🔍

Exploitinginfoanpassen

Klasse: Information Disclosure
CWE: CWE-125
ATT&CK: Unbekannt

Lokal: Nein
Remote: Teilweise

Verfügbarkeit: 🔒
Status: Nicht definiert
Preisentwicklung: 🔍
Aktuelle Preisschätzung: 🔒

0-Dayfreischaltenfreischaltenfreischaltenfreischalten
Heutefreischaltenfreischaltenfreischaltenfreischalten

Threat Intelligenceinfoanpassen

Interesse: 🔍
Aktive Akteure: 🔍
Aktive APT Gruppen: 🔍

Gegenmassnahmeninfoanpassen

Empfehlung: Patch
Status: 🔍

0-Day Time: 🔒

Patch: git.kernel.org

Timelineinfoanpassen

11.01.2022 CVE zugewiesen
28.01.2022 +17 Tage Advisory veröffentlicht
28.01.2022 +0 Tage VulDB Eintrag erstellt
30.01.2022 +2 Tage VulDB letzte Aktualisierung

Quelleninfoanpassen

Advisory: git.kernel.org
Status: Bestätigt

CVE: CVE-2022-23097 (🔒)

Eintraginfoanpassen

Erstellt: 28.01.2022 19:01
Aktualisierung: 30.01.2022 13:42
Anpassungen: (1) source_cve_nvd_summary
Komplett: 🔍

Kommentare

Bisher keine Kommentare. Sprachen: de + en.

Bitte loggen Sie sich ein, um kommentieren zu können.

Do you need the next level of professionalism?

Upgrade your account now!