wger bis 2.1 Information Disclosure

CVSS Meta Temp ScoreAktueller Exploitpreis (≈)CTI Interest Score
6.0$0-$5k0.73

In wger bis 2.1 wurde eine problematische Schwachstelle entdeckt. Es geht um unbekannter Code. Durch Beeinflussen mit einer unbekannten Eingabe kann eine Information Disclosure-Schwachstelle ausgenutzt werden. CWE definiert das Problem als CWE-307. Dies hat Einfluss auf die Vertraulichkeit. Die Zusammenfassung von CVE lautet:

Improper Restriction of Excessive Authentication Attempts in GitHub repository wger-project/wger prior to 2.2.

Die Schwachstelle wurde am 24.11.2022 öffentlich gemacht. Bereitgestellt wird das Advisory unter huntr.dev. Die Verwundbarkeit wird seit dem 04.08.2022 als CVE-2022-2650 geführt. Technische Details oder ein Exploit zur Schwachstelle sind nicht verfügbar. Als Angriffstechnik weist das MITRE ATT&CK Projekt die ID T1110.001 aus.

Ein Aktualisieren auf die Version 2.2 vermag dieses Problem zu lösen. Die Schwachstelle lässt sich auch durch das Einspielen des Patches 5e3167e3a2dc95836fa2607fe201524c031a2c4c lösen. Dieser kann von github.com bezogen werden. Als bestmögliche Massnahme wird das Upgrade auf eine neue Version empfohlen.

Produktinfo

Name

CPE 2.3info

CPE 2.2info

CVSSv3info

VulDB Meta Base Score: 6.1
VulDB Meta Temp Score: 6.0

VulDB Base Score: 4.5
VulDB Temp Score: 4.3
VulDB Vector: 🔒
VulDB Zuverlässigkeit: 🔍

CNA Base Score: 7.8
CNA Vector (huntr.dev): 🔒

CVSSv2info

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VektorKomplexitätAuthentisierungVertraulichkeitIntegritätVerfügbarkeit
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten

VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Zuverlässigkeit: 🔍

Exploitinginfo

Klasse: Information Disclosure
CWE: CWE-307 / CWE-799 / CWE-400
ATT&CK: T1110.001

Lokal: Ja
Remote: Nein

Verfügbarkeit: 🔒
Status: Nicht definiert

EPSS Score: 🔒
EPSS Percentile: 🔒

Preisentwicklung: 🔍
Aktuelle Preisschätzung: 🔒

0-Dayfreischaltenfreischaltenfreischaltenfreischalten
Heutefreischaltenfreischaltenfreischaltenfreischalten

Threat Intelligenceinfo

Interesse: 🔍
Aktive Akteure: 🔍
Aktive APT Gruppen: 🔍

Gegenmassnahmeninfo

Empfehlung: Upgrade
Status: 🔍

0-Day Time: 🔒

Upgrade: wger 2.2
Patch: 5e3167e3a2dc95836fa2607fe201524c031a2c4c

Timelineinfo

04.08.2022 CVE zugewiesen
24.11.2022 +112 Tage Advisory veröffentlicht
24.11.2022 +0 Tage VulDB Eintrag erstellt
24.11.2022 +0 Tage VulDB letzte Aktualisierung

Quelleninfo

Advisory: huntr.dev
Status: Bestätigt

CVE: CVE-2022-2650 (🔒)

Eintraginfo

Erstellt: 24.11.2022 22:27
Anpassungen: 24.11.2022 22:27 (50)
Komplett: 🔍

Diskussion

Bisher keine Kommentare. Sprachen: de + en.

Bitte loggen Sie sich ein, um kommentieren zu können.

Might our Artificial Intelligence support you?

Check our Alexa App!