Adobe Flash Player Crafted Flags Pufferüberlauf

EintraganpassenHistoryDiffjsonxmlCTI
CVSS Meta Temp ScoreAktueller Exploitpreis (≈)CTI Interest Score
6.4$0-$5k0.00

Adobe Flash ist eine proprietäre integrierte Entwicklungsumgebung zur Erstellung multimedialer Inhalte, so genannter „Flash-Filme“. Die resultierenden Dateien liegen im SWF-Format vor, einem auf Vektorgrafiken basierenden Grafik- und Animationsformat. Das Kürzel SWF steht dabei für small web format. In aktuellen Versionen besteht eine Schwachstelle, bei der ein Fehler bei "Declare Function" Tags dazu führt, dass ein heap-basierter Pufferüberlauf auftritt und die Ausführung beliebigen Codes begünstigt. Mitunter wird der Fehler auch in den Datenbanken von SecurityFocus (BID 29386), X-Force (37277), Secunia (SA30507), SecurityTracker (ID 1020114) und Vulnerability Center (SBV-18146) dokumentiert. Mit dieser Schwachstelle verwandte Einträge finden sich unter 3678, 3679, 3680 und 3681.

Für den Vulnerability Scanner Nessus wurde am 17.04.2008 ein Plugin mit der ID 31964 (SuSE 10 Security Update : flash-player (ZYPP Patch Number 5159)) herausgegeben, womit die Existenz der Schwachstelle geprüft werden kann. Es wird der Family SuSE Local Security Checks zugeordnet und im Kontext local ausgeführt. Der kommerzielle Vulnerability Scanner Qualys bietet das Plugin 115779 (Adobe Flash Player Code Execution and Security Bypass Vulnerabilities (APSB08-11)) zur Prüfung der Schwachstelle an.

Adobe's Quasi-Standard Flash kann sich glücklich schätzen: Microsofts Killerapplikation Silverlight hat diesen Monat auch eher durch negative Schlagzeilen im Zusammenhang mit DRM Implementierungen geglänzt. Anderenfalls hätten die hier beschriebenen Schwachstelle, immerhin sechs an der Zahl, wohl einen eher schalen Nachgeschmack hinterlassen. Wie immer gilt: Alte Versionen entfernen, neue Version einspielen.

Produktinfoanpassen

Typ

Hersteller

Name

CPE 2.3infoanpassen

CPE 2.2infoanpassen

CVSSv3infoanpassen

VulDB Meta Base Score: 7.3
VulDB Meta Temp Score: 6.4

VulDB Base Score: 7.3
VulDB Temp Score: 6.4
VulDB Vector: 🔍
VulDB Zuverlässigkeit: 🔍

CVSSv2infoanpassen

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VektorKomplexitätAuthentisierungVertraulichkeitIntegritätVerfügbarkeit
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Zuverlässigkeit: 🔍

NVD Base Score: 🔍

Exploitinginfoanpassen

Klasse: Unbekannt
CWE: CWE-189
ATT&CK: Unbekannt

Lokal: Nein
Remote: Ja

Verfügbarkeit: 🔍
Status: Proof-of-Concept

Preisentwicklung: 🔍
Aktuelle Preisschätzung: 🔍

0-Dayfreischaltenfreischaltenfreischaltenfreischalten
Heutefreischaltenfreischaltenfreischaltenfreischalten

Nessus ID: 31964
Nessus Name: SuSE 10 Security Update : flash-player (ZYPP Patch Number 5159)
Nessus Datei: 🔍
Nessus Risiko: 🔍
Nessus Family: 🔍
Nessus Context: 🔍
Nessus Port: 🔍

OpenVAS ID: 61120
OpenVAS Name: FreeBSD Ports: linux-flashplugin
OpenVAS Datei: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfoanpassen

Interesse: 🔍
Aktive Akteure: 🔍
Aktive APT Gruppen: 🔍

Gegenmassnahmeninfoanpassen

Empfehlung: Upgrade
Status: 🔍

Reaktionszeit: 🔍
0-Day Time: 🔍
Exposure Time: 🔍

Upgrade: adobe.com
Patch: adobe.com

Snort ID: 13820
Snort Message: WEB-CLIENT Adobe Flash player SWF scene and label data memory corruption attempt
Snort Pattern: 🔍
TippingPoint: 🔍

McAfee IPS: 🔍
McAfee IPS Version: 🔍

ISS Proventia IPS: 🔍
PaloAlto IPS: 🔍
Fortigate IPS: 🔍

Timelineinfoanpassen

04.01.2007 🔍
08.04.2008 +460 Tage 🔍
08.04.2008 +0 Tage 🔍
09.04.2008 +1 Tage 🔍
09.04.2008 +0 Tage 🔍
09.04.2008 +0 Tage 🔍
10.04.2008 +0 Tage 🔍
17.04.2008 +7 Tage 🔍
21.04.2008 +4 Tage 🔍
27.05.2008 +36 Tage 🔍
27.05.2008 +0 Tage 🔍
30.05.2008 +3 Tage 🔍
14.11.2017 +3455 Tage 🔍
08.08.2019 +632 Tage 🔍

Quelleninfoanpassen

Hersteller: https://www.adobe.com/

Advisory: adobe.com
Person: Alin Rad Pop
Firma: Secunia Research
Status: Bestätigt
Bestätigung: 🔍

CVE: CVE-2007-0071 (🔍)
OVAL: 🔍

SecurityFocus: 29386 - Retired: Adobe Flash Player SWF File Remote Code Execution Vulnerability
Secunia: 30507 - Sun Solaris update for Adobe Flash Player, Highly Critical
X-Force: 37277 - Adobe Flash Player invalid pointer integer overflow, High Risk
SecurityTracker: 1020114
Vulnerability Center: 18146 - Adobe Flash Player Integer Overflow Allows Remote Attackers to Execute Arbitrary Code, Medium
OSVDB: 44282 - Adobe Flash Player Unspecified Input Validation Arbitrary Code Execution
Vupen: ADV-2008-1724

Siehe auch: 🔍

Eintraginfoanpassen

Erstellt: 21.04.2008 12:19
Aktualisierung: 08.08.2019 11:23
Anpassungen: (1) vulnerability_discoverydate
Komplett: 🔍

Kommentare

Want to stay up to date on a daily basis?

Enable the mail alert feature now!