iScripts SocialWare events.php id SQL Injection

CVSS Meta Temp ScoreAktueller Exploitpreis (≈)CTI Interest Score
7.0$0-$5k0.00

Es wurde eine kritische Schwachstelle in iScripts SocialWare - die betroffene Version ist unbekannt - entdeckt. Es betrifft eine unbekannte Funktion der Datei events.php. Durch Beeinflussen des Arguments id mit einer unbekannten Eingabe kann eine SQL Injection-Schwachstelle ausgenutzt werden. Im Rahmen von CWE wurde eine Klassifizierung als CWE-89 vorgenommen. Auswirkungen sind zu beobachten für Vertraulichkeit, Integrität und Verfügbarkeit. CVE fasst zusammen:

SQL injection vulnerability in events.php in iScripts SocialWare allows remote attackers to execute arbitrary SQL commands via the id parameter in a show action.

Die Schwachstelle wurde am 16.04.2008 (Website) publik gemacht. Auf milw0rm.com kann das Advisory eingesehen werden. Die Verwundbarkeit wird seit dem 16.04.2008 unter CVE-2008-1859 geführt. Sie ist leicht ausnutzbar. Der Angriff kann über das Netzwerk erfolgen. Zur Ausnutzung ist keine spezifische Authentisierung erforderlich. Es sind sowohl technische Details als auch ein öffentlicher Exploit zur Schwachstelle bekannt. MITRE ATT&CK führt die Angriffstechnik T1505 für diese Schwachstelle.

Ein öffentlicher Exploit wurde durch t0pP8uZz entwickelt und schon vor und nicht nach dem Advisory veröffentlicht. Er wird als hoch funktional gehandelt. Der Exploit wird unter exploit-db.com zur Verfügung gestellt. Insgesamt wurde die Schwachstelle mindestens 9 Tage als nicht öffentlicher Zero-Day gehandelt. Während dieser Zeit erzielte er wohl etwa $0-$5k auf dem Schwarzmarkt.

Mitunter wird der Fehler auch in den Datenbanken von X-Force (41697) und Exploit-DB (5402) dokumentiert. Schwachstellen ähnlicher Art sind dokumentiert unter 41962 und 41945.

Produktinfo

Hersteller

Name

CPE 2.3info

CPE 2.2info

CVSSv3info

VulDB Meta Base Score: 7.3
VulDB Meta Temp Score: 7.0

VulDB Base Score: 7.3
VulDB Temp Score: 7.0
VulDB Vector: 🔍
VulDB Zuverlässigkeit: 🔍

CVSSv2info

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VektorKomplexitätAuthentisierungVertraulichkeitIntegritätVerfügbarkeit
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Zuverlässigkeit: 🔍

NVD Base Score: 🔍

Exploitinginfo

Klasse: SQL Injection
CWE: CWE-89
ATT&CK: T1505

Lokal: Nein
Remote: Ja

Verfügbarkeit: 🔍
Zugang: öffentlich
Status: Hoch funktional
Autor: t0pP8uZz
Download: 🔍

EPSS Score: 🔍
EPSS Percentile: 🔍

Preisentwicklung: 🔍
Aktuelle Preisschätzung: 🔍

0-Dayfreischaltenfreischaltenfreischaltenfreischalten
Heutefreischaltenfreischaltenfreischaltenfreischalten

Exploit-DB: 🔍

Threat Intelligenceinfo

Interesse: 🔍
Aktive Akteure: 🔍
Aktive APT Gruppen: 🔍

Gegenmassnahmeninfo

Empfehlung: keine Massnahme bekannt
Status: 🔍

0-Day Time: 🔍

Timelineinfo

07.04.2008 🔍
07.04.2008 +0 Tage 🔍
07.04.2008 +0 Tage 🔍
10.04.2008 +3 Tage 🔍
16.04.2008 +6 Tage 🔍
16.04.2008 +0 Tage 🔍
16.04.2008 +0 Tage 🔍
16.03.2015 +2525 Tage 🔍
19.11.2017 +979 Tage 🔍

Quelleninfo

Advisory: milw0rm.com [404 Not Found]
Status: Bestätigt

CVE: CVE-2008-1859 (🔍)
X-Force: 41697 - iScripts SocialWare events.php SQL injection
SecurityFocus: 28669 - iScripts SocialWare 'events.php' SQL Injection Vulnerability
Secunia: 29725 - iScripts SocialWare SQL Injection and File Upload Vulnerabilities, Moderately Critical
Vupen: ADV-2008-1137

scip Labs: https://www.scip.ch/?labs.20161013
Siehe auch: 🔍

Eintraginfo

Erstellt: 16.03.2015 17:00
Aktualisierung: 19.11.2017 10:17
Anpassungen: (14) vulnerability_cvss2_nvd_av vulnerability_cvss2_nvd_ac vulnerability_cvss2_nvd_au vulnerability_cvss2_nvd_ci vulnerability_cvss2_nvd_ii vulnerability_cvss2_nvd_ai exploit_availability exploit_date exploit_publicity exploit_url exploit_developer_name source_secunia_date source_exploitdb source_exploitdb_date
Komplett: 🔍

Kommentare

Bisher keine Kommentare. Sprachen: de + en.

Bitte loggen Sie sich ein, um kommentieren zu können.

Do you need the next level of professionalism?

Upgrade your account now!