VDB-98498 · CVE-2016-10130 · BID 95359

libgit2 bis 0.24.5/0.25.0 transports/http.c http_connect error erweiterte Rechte

CVSS Meta Temp ScoreAktueller Exploitpreis (≈)CTI Interest Score
6.5$0-$5k0.00

Eine kritische Schwachstelle wurde in libgit2 bis 0.24.5/0.25.0 entdeckt. Betroffen davon ist die Funktion http_connect der Datei transports/http.c. Durch Manipulation des Arguments error mit einer unbekannten Eingabe kann eine erweiterte Rechte-Schwachstelle ausgenutzt werden. Klassifiziert wurde die Schwachstelle durch CWE als CWE-284. Dies wirkt sich aus auf Vertraulichkeit, Integrität und Verfügbarkeit. CVE fasst zusammen:

The http_connect function in transports/http.c in libgit2 before 0.24.6 and 0.25.x before 0.25.1 might allow man-in-the-middle attackers to spoof servers by leveraging clobbering of the error variable.

Am 24.03.2017 wurde das Problem entdeckt. Die Schwachstelle wurde am 24.03.2017 (oss-sec) veröffentlicht. Auf openwall.com kann das Advisory eingesehen werden. Die Identifikation der Schwachstelle findet seit dem 10.01.2017 als CVE-2016-10130 statt. Der Angriff kann über das Netzwerk passieren. Das Ausnutzen erfordert keine spezifische Authentisierung. Zur Schwachstelle sind technische Details bekannt, ein verfügbarer Exploit jedoch nicht. MITRE ATT&CK führt die Angriffstechnik T1068 für diese Schwachstelle.

Für den Vulnerability Scanner Nessus wurde am 21.02.2017 ein Plugin mit der ID 97282 (openSUSE Security Update : libgit2 (openSUSE-2017-262)) herausgegeben, womit die Existenz der Schwachstelle geprüft werden kann. Es wird der Family SuSE Local Security Checks zugeordnet und im Kontext l ausgeführt. Der kommerzielle Vulnerability Scanner Qualys bietet das Plugin 276381 (Fedora Security Update for libgit2 (FEDORA-2017-403346d884)) zur Prüfung der Schwachstelle an.

Ein Upgrade auf die Version 0.24.6 oder 0.25.1 vermag dieses Problem zu beheben. Das Erscheinen einer Gegenmassnahme geschah schon vor und nicht nach der Veröffentlichung der Schwachstelle. Die Entwickler haben entsprechend vorab reagiert.

Unter anderem wird der Fehler auch in der Verwundbarkeitsdatenbank von Tenable (97282) dokumentiert.

Produktinfo

Name

Version

Lizenz

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Zuverlässigkeit: 🔍

CVSSv3info

VulDB Meta Base Score: 6.6
VulDB Meta Temp Score: 6.5

VulDB Base Score: 7.3
VulDB Temp Score: 7.0
VulDB Vector: 🔍
VulDB Zuverlässigkeit: 🔍

NVD Base Score: 5.9
NVD Vector: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VektorKomplexitätAuthentisierungVertraulichkeitIntegritätVerfügbarkeit
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Zuverlässigkeit: 🔍

NVD Base Score: 🔍

Exploitinginfo

Klasse: Erweiterte Rechte
CWE: CWE-284 / CWE-266
CAPEC: 🔍
ATT&CK: 🔍

Lokal: Nein
Remote: Ja

Verfügbarkeit: 🔍
Status: Nicht definiert

EPSS Score: 🔍
EPSS Percentile: 🔍

Preisentwicklung: 🔍
Aktuelle Preisschätzung: 🔍

0-Dayfreischaltenfreischaltenfreischaltenfreischalten
Heutefreischaltenfreischaltenfreischaltenfreischalten

Nessus ID: 97282
Nessus Name: openSUSE Security Update : libgit2 (openSUSE-2017-262)
Nessus Datei: 🔍
Nessus Risiko: 🔍
Nessus Family: 🔍
Nessus Context: 🔍

OpenVAS ID: 867773
OpenVAS Name: Fedora Update for libgit2 FEDORA-2017-403346d884
OpenVAS Datei: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfo

Interesse: 🔍
Aktive Akteure: 🔍
Aktive APT Gruppen: 🔍

Gegenmassnahmeninfo

Empfehlung: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: libgit2 0.24.6/0.25.1
Patch: github.com

Timelineinfo

10.01.2017 🔍
10.01.2017 +0 Tage 🔍
16.02.2017 +37 Tage 🔍
21.02.2017 +5 Tage 🔍
24.03.2017 +31 Tage 🔍
24.03.2017 +0 Tage 🔍
24.03.2017 +0 Tage 🔍
24.03.2017 +0 Tage 🔍
15.11.2022 +2062 Tage 🔍

Quelleninfo

Advisory: 9a64e62f0f20c9cf9b2e1609f037060eb2d8eb22
Status: Nicht definiert
Bestätigung: 🔍

CVE: CVE-2016-10130 (🔍)
SecurityFocus: 95359 - libgit2 'src/transports/http.c' Security Bypass Vulnerability
OSVDB: - CVE-2016-10130 - Git - libgit2 - Man-in-the-Middle Issue

Eintraginfo

Erstellt: 24.03.2017 18:53
Aktualisierung: 15.11.2022 08:44
Anpassungen: 24.03.2017 18:53 (75), 13.09.2020 20:26 (5), 15.11.2022 08:44 (5)
Komplett: 🔍
Cache ID: 100:FB0:40

Diskussion

Bisher keine Kommentare. Sprachen: de + en.

Bitte loggen Sie sich ein, um kommentieren zu können.

Interested in the pricing of exploits?

See the underground prices here!