jsrsasign Package hasta 8.0.16 en Node.js RSASSA-PSS desbordamiento de búfer

artículoeditHistoryDiffjsonxmlCTI
CVSS Meta Temp Score
Exploit Precio Actual (≈)
CTI Interest Score
7.0$0-$5k0.07

Una vulnerabilidad clasificada como crítica fue encontrada en jsrsasign Package hasta 8.0.16 en Node.js (JavaScript Library). Una función desconocida del componente RSASSA-PSS Handler es afectada por esta vulnerabilidad. A través de la manipulación de un input desconocido se causa una vulnerabilidad de clase desbordamiento de búfer. Esto tiene repercusión sobre la integridad y disponibilidad.

La vulnerabilidad fue publicada el 2020-06-22 (no está definido). La vulnerabilidad es identificada como CVE-2020-14968. Se considera difícil de explotar. El ataque se puede hacer desde la red. La explotación no necesita ninguna autentificación específica. No se conoce los detalles técnicos ni hay ningún exploit disponible.

Una actualización a la versión 8.0.17 elimina esta vulnerabilidad.

Productoinfoedit

Escribe

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 7.3
VulDB Meta Temp Score: 7.0

VulDB Base Score: 4.8
VulDB Temp Score: 4.6
VulDB Vector: 🔒
VulDB Confiabilidad: 🔍

NVD Base Score: 9.8
NVD Vector: 🔒

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Confiabilidad: 🔍

NVD Base Score: 🔒

Explotacióninfoedit

Clase: Desbordamiento de búfer
CWE: CWE-119
ATT&CK: Desconocido

Local: No
Remoto: Sí

Disponibilidad: 🔒
Status: No está definido

Predicción de precios: 🔍
Estimación del precio actual: 🔒

0-Dayunlockunlockunlockunlock
Hoyunlockunlockunlockunlock

Threat Intelligenceinfoedit

Amenaza: 🔍
Adversarios: 🔍
Geopolítica: 🔍
Economía: 🔍
Predicciones: 🔍
Contramedidas: 🔍

Contramedidasinfoedit

Recomendación: Upgrade
Status: 🔍

0-Day Time: 🔒

Upgrade: jsrsasign Package 8.0.17

Línea de tiempoinfoedit

2020-06-22 Publicación del advisory
2020-06-22 +0 días Asignado del CVE
2020-06-23 +1 días VulDB entrada creado
2020-10-26 +125 días VulDB entrada actualizado

Fuentesinfoedit

Status: No está definido
Confirmado: 🔒

CVE: CVE-2020-14968 (🔒)
Véase también: 🔒

Artículoinfoedit

Fecha de creación: 2020-06-23 09:48
Actualizaciones: 2020-10-26 14:00
Cambios: (1) advisory_confirm_url
Completo: 🔍

Comentarios

Might our Artificial Intelligence support you?

Check our Alexa App!