OpenDaylight hasta 0.16.4 RoleStore.java deleteRole sql injection

CVSS Meta puntuación temporalExploit Precio Actual (≈)Puntaje de interés de CTI
6.4$0-$5k0.00

Una vulnerabilidad fue encontrada en OpenDaylight hasta 0.16.4 y clasificada como crítica. La función deleteRole del archivo aaa-idm-store-h2/src/main/java/org/opendaylight/aaa/datastore/h2/RoleStore.java es afectada por esta vulnerabilidad. Por la manipulación de un input desconocido se causa una vulnerabilidad de clase sql injection. Los efectos exactos de un ataque exitoso no son conocidos. El resumen de CVE es:

La vulnerabilidad fue publicada el 2022-11-27 (confirmado). El advisory puede ser descargado de git.opendaylight.org. La vulnerabilidad es identificada como CVE-2022-45932. Detalles técnicos son conocidos, pero no hay ningún exploit público disponible.

Una actualización a la versión 0.16.5 elimina esta vulnerabilidad. Aplicando un parche es posible eliminar el problema. El parche puede ser descargado de git.opendaylight.org. El mejor modo sugerido para mitigar el problema es actualizar a la última versión.

Productoinfo

Nombre

Versión

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Confiabilidad: 🔍

CVSSv3info

VulDB Puntaje metabásico: 6.5
VulDB Meta puntuación temporal: 6.4

VulDB Puntuación base: 5.5
VulDB Puntuación temporal: 5.3
VulDB Vector: 🔍
VulDB Confiabilidad: 🔍

NVD Puntuación base: 7.5
NVD Vector: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplejidadAutenticaciónConfidencialidadIntegridadDisponibilidad
desbloqueardesbloqueardesbloqueardesbloqueardesbloqueardesbloquear
desbloqueardesbloqueardesbloqueardesbloqueardesbloqueardesbloquear
desbloqueardesbloqueardesbloqueardesbloqueardesbloqueardesbloquear

VulDB Puntuación base: 🔍
VulDB Puntuación temporal: 🔍
VulDB Confiabilidad: 🔍

Explotacióninfo

Clase: Sql injection
CWE: CWE-89 / CWE-74 / CWE-707
CAPEC: 🔍
ATT&CK: 🔍

Local: No
Remoto: En parte

Disponibilidad: 🔍
Estado: No está definido

EPSS Score: 🔍
EPSS Percentile: 🔍

Predicción de precios: 🔍
Estimación del precio actual: 🔍

0-Daydesbloqueardesbloqueardesbloqueardesbloquear
Hoydesbloqueardesbloqueardesbloqueardesbloquear

Inteligencia de Amenazasinfo

Interesar: 🔍
Actores Activos: 🔍
Grupos APT activos: 🔍

Contramedidasinfo

Recomendación: Upgrade
Estado: 🔍

Hora de 0 días: 🔍

Upgrade: OpenDaylight 0.16.5
Parche: git.opendaylight.org

Línea de tiempoinfo

2022-11-27 🔍
2022-11-27 +0 días 🔍
2022-11-27 +0 días 🔍
2022-12-23 +26 días 🔍

Fuentesinfo

Advisory: git.opendaylight.org
Estado: Confirmado

CVE: CVE-2022-45932 (🔍)
Véase también: 🔍

Artículoinfo

Fecha de creación: 2022-11-27 08:47
Actualizaciones: 2022-12-23 15:35
Cambios: 2022-11-27 08:47 (41), 2022-12-23 15:35 (11)
Completo: 🔍
Cache ID: 44:66B:40

Discusión

Sin comentarios aún. Idiomas: es + en.

Por favor inicie sesión para comentar.

Interested in the pricing of exploits?

See the underground prices here!