Observium Network Monitor rrdtool.inc.php escalada de privilegios

CVSS Meta puntuación temporalExploit Precio Actual (≈)Puntaje de interés de CTI
6.0$0-$5k0.00

Una vulnerabilidad clasificada como crítica ha sido encontrada en Observium Network Monitor. Una función desconocida del archivo /includes/rrdtool.inc.php es afectada por esta vulnerabilidad. Mediante la manipulación de un input desconocido se causa una vulnerabilidad de clase escalada de privilegios. Esto tiene repercusión sobre la confidencialidad, integridad y disponibilidad.

El error fue descubierto el 2016-09-01. La vulnerabilidad fue publicada el 2016-11-10 por Ronald Volgers con identificación [CT-2016-1110] Unauthenticated RCE in Observium network monitor con un mailinglist post (Full-Disclosure) (confirmado). El advisory puede ser descargado de seclists.org. La publicación se realizó con la cooperación del fabricante. Se considera fácil de explotar. El ataque puede ser iniciado desde la red. La explotación requiere una autentificación. Hay detalles técnicos conocidos, pero no se dispone de un exploit. El motivo de esta vulnerabilidad es esta parte del código:

function rrdtool_pipe_open(&$rrd_process, &$rrd_pipes)
{
 global $config;

 $command = $config['rrdtool'] . " -"; // Waits for input via standard input (STDIN)

 $descriptorspec = array(
    0 => array("pipe", "r"),  // stdin
    1 => array("pipe", "w"),  // stdout
    2 => array("pipe", "w")   // stderr
 );

 $cwd = $config['rrd_dir'];
 $env = array();

 $rrd_process = proc_open($command, $descriptorspec, $rrd_pipes, $cwd, $env);

Esta vulnerabilidad ha sido clasificada como un exploit día cero por lo menos por 55 días.

Una actualización elimina esta vulnerabilidad. Una solución posible ha sido publicada antes y no simplemente después de la publicación de la vulnerabilidad.

Productoinfo

Proveedor

Nombre

CPE 2.3info

CPE 2.2info

CVSSv3info

VulDB Puntaje metabásico: 6.3
VulDB Meta puntuación temporal: 6.0

VulDB Puntuación base: 6.3
VulDB Puntuación temporal: 6.0
VulDB Vector: 🔍
VulDB Confiabilidad: 🔍

CVSSv2info

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplejidadAutenticaciónConfidencialidadIntegridadDisponibilidad
desbloqueardesbloqueardesbloqueardesbloqueardesbloqueardesbloquear
desbloqueardesbloqueardesbloqueardesbloqueardesbloqueardesbloquear
desbloqueardesbloqueardesbloqueardesbloqueardesbloqueardesbloquear

VulDB Puntuación base: 🔍
VulDB Puntuación temporal: 🔍
VulDB Confiabilidad: 🔍

Explotacióninfo

Clase: Escalada de privilegios
CWE: CWE-77
ATT&CK: T1202

Local: No
Remoto: Sí

Disponibilidad: 🔍
Estado: No está definido
Predicción de precios: 🔍
Estimación del precio actual: 🔍

0-Daydesbloqueardesbloqueardesbloqueardesbloquear
Hoydesbloqueardesbloqueardesbloqueardesbloquear

Inteligencia de Amenazasinfo

Interesar: 🔍
Actores Activos: 🔍
Grupos APT activos: 🔍

Contramedidasinfo

Recomendación: Upgrade
Estado: 🔍

Tiempo de reacción: 🔍
Hora de 0 días: 🔍

Upgrade: seclists.org

Línea de tiempoinfo

2016-09-01 🔍
2016-10-21 +50 días 🔍
2016-10-21 +0 días 🔍
2016-10-26 +5 días 🔍
2016-11-10 +15 días 🔍
2016-11-11 +1 días 🔍
2019-05-30 +930 días 🔍

Fuentesinfo

Advisory: [CT-2016-1110] Unauthenticated RCE in Observium network monitor
Investigador: Ronald Volgers
Estado: Confirmado
Coordinar: 🔍
Véase también: 🔍

Artículoinfo

Fecha de creación: 2016-11-11 15:54
Actualizaciones: 2019-05-30 09:27
Cambios: (1) vulnerability_cwe
Completo: 🔍

Comentarios

Sin comentarios aún. Idiomas: es + en.

Por favor inicie sesión para comentar.

Want to stay up to date on a daily basis?

Enable the mail alert feature now!