Directadmin Controlpanel 1.50.1 /CMD_SELECT_USERS location cross site scripting

CVSS Score de méta-températureExploit Prix Actuel (≈)Score d'intérêt CTI
3.2$0-$5k0.00

Une vulnérabilité classée problématique a été trouvée dans Directadmin Controlpanel 1.50.1. Affecté est une fonction inconnue du fichier /CMD_SELECT_USERS. La manipulation du paramètre location de la valeur d'entrée CMD_ALL_USER_SHOW'"><script>alert(/IrIsT.Ir/)</script> mène à une vulnérabilité de classe cross site scripting.

La vulnerabilité a été publié en 10/01/2017 par Amir avec le numéro d'identification Directadmin ControlPanel 1.50.1 Cross-Site-Scripting Vulnerability avec mailinglist post (Bugtraq) (non défini). La notice d'information est disponible en téléchargement sur seclists.org Il est possible de lancer l'attaque à distance. Des details techniques et un publique exploit sont connus.

Un exploit a été developpé par Amir en URL et a été publié immédiatement après la notice d'information. Il est déclaré comme proof-of-concept. L'exploit est disponible au téléchargment sur seclists.org. Le code utilisé par l'exploit est:

http://ip:2222/CMD_SELECT_USERS?select3=irist.ir(site)&dosuspend=Suspend&reason=none&location=CMD_ALL_USER_SHOW'"><script>alert(/IrIsT.Ir/)</script>

Il n'y a aucune information à propos de possibles contremesures connues. Il est suggéré de remplacer l'object infecté par un produit alternatif.

Produitinfo

Fournisseur

Nom

CPE 2.3info

CPE 2.2info

CVSSv3info

VulDB Score méta-base: 3.5
VulDB Score de méta-température: 3.2

VulDB Note de base: 3.5
VulDB Note temporaire: 3.2
VulDB Vecteur: 🔍
VulDB Fiabilité: 🔍

CVSSv2info

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VecteurComplexitéAuthentificationConfidentialitéIntégritéDisponibilité
ouvrirouvrirouvrirouvrirouvrirouvrir
ouvrirouvrirouvrirouvrirouvrirouvrir
ouvrirouvrirouvrirouvrirouvrirouvrir

VulDB Note de base: 🔍
VulDB Note temporaire: 🔍
VulDB Fiabilité: 🔍

Exploitinginfo

Classe: Cross site scripting
CWE: CWE-80 / CWE-74 / CWE-707
ATT&CK: T1059.007

Localement: Non
Remote: Oui

Disponibilité: 🔍
Accéder: Publique
Statut: Proof-of-Concept
Auteur: Amir
Langage de programmation: 🔍
Télécharger: 🔍
Prédiction de prix: 🔍
Estimation actuelle des prix: 🔍

0-Dayouvrirouvrirouvrirouvrir
Aujourd'huiouvrirouvrirouvrirouvrir

Renseignements sur les menacesinfo

Intérêt: 🔍
Acteurs actifs: 🔍
Groupes APT actifs: 🔍

Contre-mesuresinfo

Recommandé: aucune mesure d'atténuation connue
Statut: 🔍

Heure 0 jour: 🔍
Délai d'exploitation: 🔍

Chronologieinfo

10/01/2017 🔍
10/01/2017 +0 jours 🔍
11/01/2017 +1 jours 🔍
19/07/2020 +1285 jours 🔍

Sourcesinfo

Bulletin: Directadmin ControlPanel 1.50.1 Cross-Site-Scripting Vulnerability
Chercheur: Amir
Statut: Non défini
scip Labs: https://www.scip.ch/en/?labs.20161013

Entréeinfo

Établi: 11/01/2017 15:09
Mise à jour: 19/07/2020 12:57
Changements: (1) vulnerability_cwe
Compléter: 🔍

commentaires

Aucun commentaire pour l'instant. Langues: fr + en.

Veuillez vous connecter pour commenter.

Might our Artificial Intelligence support you?

Check our Alexa App!