jsrsasign Package fino 8.0.16 su Node.js RSASSA-PSS buffer overflow

voceeditHistoryDiffjsonxmlCTI
CVSS Meta Temp Score
Exploit Prezzo Attuale (≈)
CTI Interest Score
7.0$0-$5k0.00

Una vulnerabilità di livello critico è stata rilevata in jsrsasign Package fino 8.0.16 su Node.js (JavaScript Library). Interessato da questa vulnerabilità è una funzione sconosciuta del componente RSASSA-PSS Handler. La manipolazione di un input sconosciuto se causa una vulnerabilità di classe buffer overflow. Questo ha effetti su integrità e disponibilità.

La vulnerabilità è stata pubblicata in data 22/06/2020 (non definito). Questa vulnerabilità è identificata come CVE-2020-14968. È difficoltoso da sfruttare. L'attacco può avvenire nella rete. L'utilizzo non richiede alcuna forma di autentificazione. Dettagli tecnici e metodo d'utilizzo , non sono a disposizione.

L'aggiornamento alla versione 8.0.17 elimina questa vulnerabilità.

Prodottoinfoedit

genere

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 7.3
VulDB Meta Temp Score: 7.0

VulDB Base Score: 4.8
VulDB Temp Score: 4.6
VulDB Vector: 🔒
VulDB Affidabilità: 🔍

NVD Base Score: 9.8
NVD Vector: 🔒

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Affidabilità: 🔍

NVD Base Score: 🔒

Exploitinginfoedit

Classe: Buffer overflow
CWE: CWE-119
ATT&CK: Sconosciuto

Locale: No
Remoto: Si

Disponibilità: 🔒
Status: Non definito

Previsione dei prezzi: 🔍
Preventivo attuale: 🔒

0-Dayunlockunlockunlockunlock
Oggiunlockunlockunlockunlock

Threat Intelligenceinfoedit

Minaccia: 🔍
Avversari: 🔍
Geopolitica: 🔍
Economia: 🔍
Predizioni: 🔍
Contromisure: 🔍

Contromisureinfoedit

Raccomandazione: Upgrade
Status: 🔍

0-Day Time: 🔒

Upgrade: jsrsasign Package 8.0.17

Sequenza temporaleinfoedit

22/06/2020 Pubblicazione advisory
22/06/2020 +0 giorni CVE assegnato
23/06/2020 +1 giorni VulDB voce creata
26/10/2020 +125 giorni VulDB voce aggiornata

Fontiinfoedit

Status: Non definito
Confermato: 🔒

CVE: CVE-2020-14968 (🔒)
Vedi anche: 🔒

Voceinfoedit

Data di creazione: 23/06/2020 09:48
Aggiornamenti: 26/10/2020 14:00
I cambiamenti: (1) advisory_confirm_url
Completa: 🔍

Commenti

Ancora nessun commento. Effettua il login per commentare.

Are you interested in using VulDB?

Download the whitepaper to learn more about our service!