PostgreSQL まで9.0.18/9.1.14/9.2.9/9.3.5/9.4.0 to_char メモリ破損

CVSS 一時的なメタスコア現在のエクスプロイト価格 (≈)CTI注目指数
7.1$0-$5k0.00

脆弱性が PostgreSQL まで9.0.18/9.1.14/9.2.9/9.3.5/9.4.0 内に見つかりました。この脆弱性は 問題がある として分類されました。 この脆弱性により影響を受けるのは、関数【to_char】です。 未知の値で改ざんすることが、 メモリ破損を突く攻撃に繋がります。 この脆弱性に対応するCWEの定義は CWE-119 です。 この脆弱性は 2015年02月05日に Bruce Momjianより「Website」の Newsにて 「News ID 1569」として 紹介されました。 アドバイザリーは postgresql.org で共有されています。

この脆弱性は CVE-2015-0241 として扱われます。 CVEの割り当ては 2014年11月18日 に行われました。 技術的詳細情報が入手可能です。 入手できるエクスプロイトツールはありません。 現時点で、エクスプロイトツールの価格はおそらく米ドルで約$0-$5kです。

0dayにはおよそ $0-$5k の価値があったと予想しています。 脆弱性スキャナーNessusはID【81193 (FreeBSD : PostgreSQL -- multiple buffer overflows and memory issues (3b40bf2c-ad83-11e4-a2b2-0026551a22dc))】のプラグインを提供しています。不具合の有無をターゲット環境にて判定できます。 これは【FreeBSD Local Security Checks 】に分類されています。 商用脆弱性スキャナーQualysではプラグイン【 350210 (Amazon Linux Security Advisory for postgresql92: ALAS-2015-492) 】を使用してこの問題をテストできます。

バージョン 9.0.19, 9.1.15, 9.2.10, 9.3.6 , 9.4.1 をアップグレードすることで、この問題に対処できます。 影響を受けているコンポーネントのアップグレードを推奨します。 考えられる回避策が、前として脆弱性の公開後公表されました 。 アドバイザリーには次の備考が含まれています。

This vulnerability was fixed on non-Windows platforms in the prior update releases.

脆弱性は「SecurityFocus (BID 72540), X-Force (100777), SecurityTracker (ID 1031742), Vulnerability Center (SBV-52641) , Tenable (81193)」等の脆弱性データベースにも文書化されています。

製品情報

タイプ

名前

バージョン

ライセンス

CPE 2.3情報

CPE 2.2情報

CVSSv4情報

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB 方向性: 🔍
VulDB 信頼性: 🔍

CVSSv3情報

VulDB ベースメタスコア: 7.5
VulDB 一時的なメタスコア: 7.1

VulDB ベーススコア: 6.3
VulDB 一時的なスコア: 5.5
VulDB 方向性: 🔍
VulDB 信頼性: 🔍

NVD ベーススコア: 8.8
NVD 方向性: 🔍

CVSSv2情報

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
方向性複雑度認証守秘義務性誠実性可用性
解除解除解除解除解除解除
解除解除解除解除解除解除
解除解除解除解除解除解除

VulDB ベーススコア: 🔍
VulDB 一時的なスコア: 🔍
VulDB 信頼性: 🔍

NVD ベーススコア: 🔍

悪用する情報

クラス: メモリ破損
CWE: CWE-119
CAPEC: 🔍
ATT&CK: 🔍

ローカル: いいえ
リモート: はい

可用性: 🔍
ステータス: 未実証

EPSS Score: 🔍
EPSS Percentile: 🔍

価格予測: 🔍
現在の価格評価: 🔍

0-Day解除解除解除解除
本日解除解除解除解除

Nessus ID: 81193
Nessus 名前: FreeBSD : PostgreSQL -- multiple buffer overflows and memory issues (3b40bf2c-ad83-11e4-a2b2-0026551a22dc)
Nessus ファイル: 🔍
Nessus リスク: 🔍
Nessus ファミリー: 🔍

OpenVAS ID: 14611
OpenVAS 名前: Amazon Linux Local Check: ALAS-2015-503
OpenVAS ファイル: 🔍
OpenVAS ファミリー: 🔍

Qualys ID: 🔍
Qualys 名前: 🔍

脅威インテリジェンス情報

関心: 🔍
アクティブ アクター: 🔍
アクティブな APT グループ: 🔍

対策情報

推奨: アップグレード
ステータス: 🔍

0day日時: 🔍

アップグレード: PostgreSQL 9.0.19/9.1.15/9.2.10/9.3.6/9.4.1

タイムライン情報

2014年11月18日 🔍
2015年02月05日 +79 日 🔍
2015年02月05日 +0 日 🔍
2015年02月11日 +6 日 🔍
2015年02月11日 +0 日 🔍
2015年09月16日 +217 日 🔍
2015年09月17日 +1 日 🔍
2022年03月09日 +2365 日 🔍

ソース情報

製品: postgresql.org

アドバイザリー: News ID 1569
調査者: Bruce Momjian
ステータス: 確認済み

CVE: CVE-2015-0241 (🔍)
OVAL: 🔍

X-Force: 100777 - PostgreSQL to_char buffer overflow, Medium Risk
SecurityTracker: 1031742
Vulnerability Center: 52641 - PostgreSQL Remote Code Execution due to Processing a Crafted Timestamp Formatting Template, Medium
SecurityFocus: 72540 - PostgreSQL 'to_char()' Function Buffer Overflow Vulnerability

エントリ情報

作成済み: 2015年02月11日 09:05
更新済み: 2022年03月09日 02:26
変更: 2015年02月11日 09:05 (67), 2017年12月23日 13:14 (8), 2022年03月09日 02:11 (2), 2022年03月09日 02:19 (18), 2022年03月09日 02:26 (1)
完了: 🔍
Cache ID: 3:C5F:40

討論

コメントはまだありません。 言語: ja + en.

コメントするにはログインしてください。

Do you need the next level of professionalism?

Upgrade your account now!