PostgreSQL till 9.0.18/9.1.14/9.2.9/9.3.5/9.4.0 to_char minneskorruption

CVSS Meta Temp poängNuvarande exploateringspris (≈)CTI intressepoäng
7.1$0-$5k0.00

I PostgreSQL till 9.0.18/9.1.14/9.2.9/9.3.5/9.4.0 (Database Software) var en problematiskt svag punkt finns. Som påverkar funktionen to_char. Manipulering en okänd ingång leder till en sårbarhet klass minneskorruption svag punkt.

Den svaga punkten är publicerad 05/02/2015 av Bruce Momjian som News ID 1569 i en form news (Website) (bekräftad). Den rådgivande finns tillgänglig för nedladdning på postgresql.org. Denna svaga punkt är känd som CVE-2015-0241. Attacken på nätet kan. För en enkel autentisering utnyttjats krävs. Det finns tekniska detaljer, men ingen exploit känd.

För vulnerability scanner Nessus en plugin har släppts med ID 81193 (FreeBSD : PostgreSQL -- multiple buffer overflows and memory issues (3b40bf2c-ad83-11e4-a2b2-0026551a22dc)), så att sårbarheten kan testas.

En uppgradering till den version 9.0.19, 9.1.15, 9.2.10, 9.3.6 eller 9.4.1 att åtgärda problemet.

Sårbarheten dokumenteras i databaser X-Force (100777) och Tenable (81193).

Produktinfo

Typ

namn

Version

Licens

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vektor: 🔍
VulDB Pålitlighet: 🔍

CVSSv3info

VulDB Meta Basscore: 7.5
VulDB Meta Temp poäng: 7.1

VulDB Baspoäng: 6.3
VulDB Temp Betyg: 5.5
VulDB Vektor: 🔍
VulDB Pålitlighet: 🔍

NVD Baspoäng: 8.8
NVD Vektor: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VektorKomplexitetAutentiseringSekretessIntegritetTillgänglighet
låsa upplåsa upplåsa upplåsa upplåsa upplåsa upp
låsa upplåsa upplåsa upplåsa upplåsa upplåsa upp
låsa upplåsa upplåsa upplåsa upplåsa upplåsa upp

VulDB Baspoäng: 🔍
VulDB Temp Betyg: 🔍
VulDB Pålitlighet: 🔍

NVD Baspoäng: 🔍

Utnyttjarinfo

Klass: Minneskorruption
CWE: CWE-119
CAPEC: 🔍
ATT&CK: 🔍

Lokal: Nej
Avlägsen: Ja

Tillgänglighet: 🔍
Status: Obevisat

EPSS Score: 🔍
EPSS Percentile: 🔍

Pris förutsägelse: 🔍
Nuvarande prisuppskattning: 🔍

0-Daylåsa upplåsa upplåsa upplåsa upp
I daglåsa upplåsa upplåsa upplåsa upp

Nessus ID: 81193
Nessus namn: FreeBSD : PostgreSQL -- multiple buffer overflows and memory issues (3b40bf2c-ad83-11e4-a2b2-0026551a22dc)
Nessus Fil: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍

OpenVAS ID: 14611
OpenVAS namn: Amazon Linux Local Check: ALAS-2015-503
OpenVAS Fil: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys namn: 🔍

Hotinformationinfo

Intressera: 🔍
Aktiva skådespelare: 🔍
Aktiva APT-grupper: 🔍

Motåtgärderinfo

Rekommenderad: Upgrade
Status: 🔍

0-dagars tid: 🔍

Upgrade: PostgreSQL 9.0.19/9.1.15/9.2.10/9.3.6/9.4.1

Tidslinjeinfo

18/11/2014 🔍
05/02/2015 +79 dagar 🔍
05/02/2015 +0 dagar 🔍
11/02/2015 +6 dagar 🔍
11/02/2015 +0 dagar 🔍
16/09/2015 +217 dagar 🔍
17/09/2015 +1 dagar 🔍
09/03/2022 +2365 dagar 🔍

Källorinfo

Produkt: postgresql.org

Rådgivande: News ID 1569
Forskare: Bruce Momjian
Status: Bekräftad

CVE: CVE-2015-0241 (🔍)
OVAL: 🔍

X-Force: 100777 - PostgreSQL to_char buffer overflow, Medium Risk
SecurityTracker: 1031742
Vulnerability Center: 52641 - PostgreSQL Remote Code Execution due to Processing a Crafted Timestamp Formatting Template, Medium
SecurityFocus: 72540 - PostgreSQL 'to_char()' Function Buffer Overflow Vulnerability

Inträdeinfo

Skapad: 11/02/2015 09:05
Uppdaterad: 09/03/2022 02:26
Ändringar: 11/02/2015 09:05 (67), 23/12/2017 13:14 (8), 09/03/2022 02:11 (2), 09/03/2022 02:19 (18), 09/03/2022 02:26 (1)
Komplett: 🔍
Cache ID: 100:5F5:40

Diskussion

Inga kommentarer än. språk: sv + en.

Logga in för att kommentera.

Do you want to use VulDB in your project?

Use the official API to access entries easily!