Google Android 直到4.x/5.x Kernel entry_32.S 权限升级

CVSS 元温度得分当前攻击价格 (≈)CTI兴趣分数
7.4$0-$5k0.00

在 Google Android 直到4.x/5.x中曾发现一漏洞,此漏洞被分类为致命。 受影响的是未知功能文件:entry_32.S的组件:Kernel。 手动调试的不合法输入可导致 权限升级。 使用CWE来声明会导致 CWE-264 的问题。 此漏洞的脆弱性 2016-04-04由公示人Andy Lutomirski、公示人身份ANDROID-26927260、公示人类型为Security Bulletin (Website)所披露。 索取公告的网址是source.android.com

该漏洞的交易名称为CVE-2014-9322, CVE分配信息格式:2014-12-07。 有技术细节可用。 该漏洞的知名度高于平均水平, 此外还有一个漏洞可利用。 该漏洞利用已公开,可能会被利用。 目前漏洞的结构决定了可能的价格范围为美元价USD $0-$5k。 该漏洞由MITRE ATT&CK项目分配为T1068。 导致该漏洞的是这一部分代码:

larl PT_OLDSS(%esp), %eax
jnz restore_nocheck
testl $0x00400000, %eax		# returning to 32bit stack?
jnz restore_nocheck		# allright, normal return

它被宣布为proof-of-concept。 该漏洞利用的共享下载地址为:securityfocus.com。 估计零日攻击的地下价格约为$25k-$100k。 漏洞扫描器Nessus提供了一个插件,插件ID为79725 (Amazon Linux AMI : kernel (ALAS-2014-455))有助于判断目标环境中是否存在缺陷, 它已分配至系列:Amazon Linux Local Security Checks, 该插件在类型为local的背景下运行。 商业漏洞扫描器Qualys能够使用插件167410 (SUSE Enterprise Linux Security update for Linux kernel (SUSE-SU-2014:1698-1))检测此问题。

升级到版本6.0 , 6.0.1能够解决此问题。 建议对受到影响的组件升级。 该漏洞被披露后,立即发表过可能的缓解措施。

该漏洞也记录在其他漏洞数据库中: SecurityFocus (BID 71685), Secunia (SA62336), Vulnerability Center (SBV-57898) , Tenable (79725)。

产品信息

类型

供应商

名称

CPE 2.3信息

CPE 2.2信息

CVSSv3信息

VulDB 元基础分数: 7.8
VulDB 元温度得分: 7.4

VulDB 基本分数: 7.8
VulDB 温度得分: 7.0
VulDB 向量: 🔍
VulDB 可靠性: 🔍

NVD 基本分数: 7.8
NVD 向量: 🔍

CVSSv2信息

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
向量复杂度身份验证保密正直可用性
开锁开锁开锁开锁开锁开锁
开锁开锁开锁开锁开锁开锁
开锁开锁开锁开锁开锁开锁

VulDB 基本分数: 🔍
VulDB 温度得分: 🔍
VulDB 可靠性: 🔍

NVD 基本分数: 🔍

攻击信息

分类: 权限升级
CWE: CWE-264
ATT&CK: T1068

本地: 是
远程: 否

可用性: 🔍
访问: 公共
地位: Proof-of-Concept
编程语言: 🔍
下载: 🔍

EPSS Score: 🔍
EPSS Percentile: 🔍

价格预测: 🔍
当前价格估算: 🔍

0-Day开锁开锁开锁开锁
今天开锁开锁开锁开锁

Nessus ID: 79725
Nessus 名称: Amazon Linux AMI : kernel (ALAS-2014-455)
Nessus 文件: 🔍
Nessus 风险: 🔍
Nessus 家庭: 🔍
Nessus Context: 🔍

OpenVAS ID: 14611
OpenVAS 名称: Amazon Linux Local Check: ALAS-2014-455
OpenVAS 文件: 🔍
OpenVAS 家庭: 🔍

Qualys ID: 🔍
Qualys 名称: 🔍

Exploit-DB: 🔍

威胁情报信息

利益: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

对策信息

建议: 升级
地位: 🔍

反应时间: 🔍
0天时间: 🔍
曝光时间: 🔍

升级: Android 6.0/6.0.1
补丁: 6f442be2fb22be02cafa606f1769fa1e6f894441

时间轴信息

2014-12-05 🔍
2014-12-07 +2 日 🔍
2014-12-15 +8 日 🔍
2014-12-17 +2 日 🔍
2015-01-14 +28 日 🔍
2015-03-04 +49 日 🔍
2015-12-25 +296 日 🔍
2016-04-04 +101 日 🔍
2016-04-04 +0 日 🔍
2016-04-05 +1 日 🔍
2016-04-05 +0 日 🔍
2022-07-12 +2289 日 🔍

来源信息

供应商: google.com

公告: ANDROID-26927260
研究人员: Andy Lutomirski
地位: 已确认
确认: 🔍

CVE: CVE-2014-9322 (🔍)
OVAL: 🔍

Vulnerability Center: 57898 - Google Android 6.0 and 6.0.1 before 2016-04-02 Remote Code Execution in Kernel - CVE-2014-9322, Critical
SecurityFocus: 71685 - Linux Kernel CVE-2014-9322 Local Privilege Escalation Vulnerability
Secunia: 62336 - Ubuntu update for kernel, Less Critical
OSVDB: 115919

scip Labs: https://www.scip.ch/en/?labs.20150917
另见: 🔍

条目信息

已创建: 2016-04-05 09時13分
已更新: 2022-07-12 08時16分
更改: (10) vulnerability_cvss3_meta_tempscore vulnerability_cvss3_nvd_basescore vulnerability_cvss3_nvd_av vulnerability_cvss3_nvd_ac vulnerability_cvss3_nvd_pr vulnerability_cvss3_nvd_ui vulnerability_cvss3_nvd_s vulnerability_cvss3_nvd_c vulnerability_cvss3_nvd_i vulnerability_cvss3_nvd_a
完整: 🔍

评论

暂时没有任何评论。 语言: zh + en.

请登录后发表评论。

Are you interested in using VulDB?

Download the whitepaper to learn more about our service!