OneDev hasta 4.0.2 XML Document XmlBuildSpecMigrator.migrate divulgación de información

artículoeditHistoryDiffjsonxmlCTI
CVSS Meta Temp Score
Exploit Precio Actual (≈)
CTI Interest Score
5.1$0-$5k0.00

Una vulnerabilidad clasificada como problemática ha sido encontrada en OneDev hasta 4.0.2. La función XmlBuildSpecMigrator.migrate del componente XML Document Handler es afectada por esta vulnerabilidad. Por la manipulación de un input desconocido se causa una vulnerabilidad de clase divulgación de información. Esto tiene repercusión sobre la la confidencialidad.

La vulnerabilidad fue publicada el 2021-01-16 (confirmado). El advisory puede ser descargado de github.com. La vulnerabilidad es identificada como CVE-2021-21250. Se considera fácil de explotar. El ataque puede ser iniciado desde la red. La explotación requiere una autentificación. Hay detalles técnicos conocidos, pero no se dispone de un exploit.

Una actualización a la versión 4.0.3 elimina esta vulnerabilidad. Aplicando un parche es posible eliminar el problema. El parche puede ser descargado de github.com. El mejor modo sugerido para mitigar el problema es actualizar a la última versión.

Productoinfoedit

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 5.4
VulDB Meta Temp Score: 5.1

VulDB Base Score: 4.3
VulDB Temp Score: 4.1
VulDB Vector: 🔒
VulDB Confiabilidad: 🔍

NVD Base Score: 6.5
NVD Vector: 🔒

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Confiabilidad: 🔍

NVD Base Score: 🔒

Explotacióninfoedit

Clase: Divulgación de información
CWE: CWE-200
ATT&CK: Desconocido

Local: No
Remoto: Sí

Disponibilidad: 🔒
Status: No está definido

Predicción de precios: 🔍
Estimación del precio actual: 🔒

0-Dayunlockunlockunlockunlock
Hoyunlockunlockunlockunlock

Threat Intelligenceinfoedit

Amenaza: 🔍
Adversarios: 🔍
Geopolítica: 🔍
Economía: 🔍
Predicciones: 🔍
Contramedidas: 🔍

Contramedidasinfoedit

Recomendación: Upgrade
Status: 🔍

0-Day Time: 🔒

Upgrade: OneDev 4.0.3
Parche: github.com

Línea de tiempoinfoedit

2020-12-22 Asignado del CVE
2021-01-16 +25 días Publicación del advisory
2021-01-16 +0 días VulDB entrada creado
2021-02-15 +30 días VulDB entrada actualizado

Fuentesinfoedit

Advisory: github.com
Status: Confirmado
Confirmado: 🔒

CVE: CVE-2021-21250 (🔒)

Artículoinfoedit

Fecha de creación: 2021-01-16 09:28
Actualizaciones: 2021-02-15 02:39
Cambios: (19) vulnerability_cvss3_nvd_av vulnerability_cvss3_nvd_ac vulnerability_cvss3_nvd_pr vulnerability_cvss3_nvd_ui vulnerability_cvss3_nvd_s vulnerability_cvss3_nvd_c vulnerability_cvss3_nvd_i vulnerability_cvss3_nvd_a vulnerability_cvss2_nvd_av vulnerability_cvss2_nvd_ac vulnerability_cvss2_nvd_au vulnerability_cvss2_nvd_ci vulnerability_cvss2_nvd_ii vulnerability_cvss2_nvd_ai source_cve_cna vulnerability_cvss3_meta_basescore vulnerability_cvss3_meta_tempscore vulnerability_cvss2_nvd_basescore vulnerability_cvss3_nvd_basescore
Completo: 🔍

Comentarios

Do you want to use VulDB in your project?

Use the official API to access entries easily!