LogMeIn LastPass à 4.9.1 onloadwff.js HTML Document dénie de service

CVSS Score de méta-températureExploit Prix Actuel (≈)Score d'intérêt CTI
5.6$0-$5k0.00

Une vulnérabilité a été trouvé dans LogMeIn LastPass à 4.9.1 et classée problématique. Affecté par cette vulnérabilité est une fonction inconnue du fichier onloadwff.js. A cause de la manipulation dans le cadre de HTML Document mène à une vulnérabilité de classe dénie de service.

Le bug a été découvert sur 28/12/2017. La vulnerabilité a été publié en 18/04/2018 par Steve Birstok (haykuro) (Website) (non défini). La notice d'information est disponible en téléchargement sur forums.lastpass.com Cette vulnérabilité a été nommée CVE-2018-10193. L'attaque peut être lancée à distance. Aucune forme d'authentification est requise pour l'exploitation. Des details techniques et aussi un publique exploit sont connus.

Un exploit a été developpé par Steve Birstok (haykuro) en HTML/Javascript et a été publié immédiatement après la notice d'information. Il est déclaré comme proof-of-concept. L'exploit est disponible au téléchargment sur gist.githack.com. Cette vulnérabilité a été classée comme 0-day non publique pendant au moins 110 jours.

Il n'y a aucune information à propos de possibles contremesures connues. Il est suggéré de remplacer l'object infecté par un produit alternatif.

Produitinfo

Fournisseur

Nom

CPE 2.3info

CPE 2.2info

CVSSv3info

VulDB Score méta-base: 5.9
VulDB Score de méta-température: 5.8

VulDB Note de base: 4.3
VulDB Note temporaire: 4.1
VulDB Vecteur: 🔍
VulDB Fiabilité: 🔍

NVD Note de base: 7.5
NVD Vecteur: 🔍

CVSSv2info

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VecteurComplexitéAuthentificationConfidentialitéIntégritéDisponibilité
ouvrirouvrirouvrirouvrirouvrirouvrir
ouvrirouvrirouvrirouvrirouvrirouvrir
ouvrirouvrirouvrirouvrirouvrirouvrir

VulDB Note de base: 🔍
VulDB Note temporaire: 🔍
VulDB Fiabilité: 🔍

NVD Note de base: 🔍

Exploitinginfo

Classe: Dénie de service
CWE: CWE-404
ATT&CK: T1499

Localement: Non
Remote: Oui

Disponibilité: 🔍
Accéder: Publique
Statut: Proof-of-Concept
Auteur: Steve Birstok (haykuro)
Langage de programmation: 🔍
Télécharger: 🔍

EPSS Score: 🔍
EPSS Percentile: 🔍

Prédiction de prix: 🔍
Estimation actuelle des prix: 🔍

0-Dayouvrirouvrirouvrirouvrir
Aujourd'huiouvrirouvrirouvrirouvrir

Renseignements sur les menacesinfo

Intérêt: 🔍
Acteurs actifs: 🔍
Groupes APT actifs: 🔍

Contre-mesuresinfo

Recommandé: aucune mesure d'atténuation connue
Statut: 🔍

Heure 0 jour: 🔍
Délai d'exploitation: 🔍

Chronologieinfo

28/12/2017 🔍
17/04/2018 +109 jours 🔍
17/04/2018 +0 jours 🔍
18/04/2018 +1 jours 🔍
18/04/2018 +0 jours 🔍
18/04/2018 +0 jours 🔍
01/02/2020 +654 jours 🔍

Sourcesinfo

Bulletin: forums.lastpass.com
Chercheur: Steve Birstok (haykuro)
Statut: Non défini

CVE: CVE-2018-10193 (🔍)
scip Labs: https://www.scip.ch/en/?labs.20161013

Entréeinfo

Établi: 18/04/2018 09:45
Mise à jour: 01/02/2020 13:38
Changements: 18/04/2018 09:45 (54), 01/05/2018 11:59 (2), 01/05/2018 12:00 (5), 01/05/2018 12:01 (4), 01/02/2020 13:38 (1)
Compléter: 🔍
Committer: haykuro

Discussion

haykuro (+1)
5 years ago
A PoC is available here: https://gist.githack.com/anonymous/6aea35595465b8682e63b32a309995b5/raw/5dcf5ab8bcee753c07931c673b7f0912e480c21e/last_pass_demo.html

More info here: https://forums.lastpass.com/viewtopic.php?f=12&t=286955

Write up coming soon.

Do you want to use VulDB in your project?

Use the official API to access entries easily!