rubyzip Gem fino 1.2.1 Zip::File escalazione di privilegi

CVSS Punteggio Meta TempExploit Prezzo Attuale (≈)Punteggio di interesse CTI
8.0$0-$5k0.00

In rubyzip Gem fino 1.2.1 (Programming Language Software) è stato trovato un punto critico di livello critico. Da questa vulnerabilità è interessato la funzione Zip::File. Per causa della manipolazione del valore di input ../ se causa una vulnerabilità di classe escalazione di privilegi. Effetti sono da osservare per integrità e disponibilità.

Data di scoperta del problema 15/06/2018. La vulnerabilità è stata pubblicata in data 26/06/2018 (Website) (non definito). L'advisory è scaricabile da github.com. Questa vulnerabilità è identificata come CVE-2018-1000544. L'utilità è conosciuta come semplice. Nella rete si effettua l'attacco. L'utilizzo non richiede alcuna forma di autentificazione. Sono disponibili dettagli tecnici, ma nessun metodo di utilizzo.

Questa vulnerabilità è stata classificata come un 0-day exploit almeno per 11 giorni. È disponibile un plugin per lo scanner Nessus, numero ID 111764 (Debian DLA-1467-1 : ruby-zip security update), che può aiutare a determinare l'esistenza della criticità nel sistema analizzato.

L'aggiornamento elimina questa vulnerabilità. Una possibile soluzione è stata pubblicata 2 mesi dopo la pubblicazione della vulnerabilità.

La vulnerabilità è documentata anche nei database Tenable (111764).

Prodottoinfo

Genere

Nome

Versione

CPE 2.3info

CPE 2.2info

CVSSv3info

VulDB Punteggio meta-base: 8.1
VulDB Punteggio Meta Temp: 8.0

VulDB Punteggio di base: 6.5
VulDB Punteggio temporaneo: 6.2
VulDB Vettore: 🔍
VulDB Affidabilità: 🔍

NVD Punteggio di base: 9.8
NVD Vettore: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VettoreComplessitàAutenticazioneRiservatezzaIntegritàDisponibilità
sbloccaresbloccaresbloccaresbloccaresbloccaresbloccare
sbloccaresbloccaresbloccaresbloccaresbloccaresbloccare
sbloccaresbloccaresbloccaresbloccaresbloccaresbloccare

VulDB Punteggio di base: 🔍
VulDB Punteggio temporaneo: 🔍
VulDB Affidabilità: 🔍

NVD Punteggio di base: 🔍

Exploitinginfo

Classe: Escalazione di privilegi
CWE: CWE-434 / CWE-284 / CWE-266
ATT&CK: T1608.002

Locale: No
Remoto: Si

Disponibilità: 🔍
Stato: Non definito

EPSS Score: 🔍
EPSS Percentile: 🔍

Previsione dei prezzi: 🔍
Preventivo attuale: 🔍

0-Daysbloccaresbloccaresbloccaresbloccare
Oggisbloccaresbloccaresbloccaresbloccare

Nessus ID: 111764
Nessus Nome: Debian DLA-1467-1 : ruby-zip security update
Nessus File: 🔍
Nessus Rischio: 🔍
Nessus Family: 🔍
Nessus Context: 🔍

Intelligence Sulle Minacceinfo

Interesse: 🔍
Attori Attivi: 🔍
Gruppi APT attivi: 🔍

Contromisureinfo

Raccomandazione: Upgrade
Stato: 🔍

Tempo di reazione: 🔍
0 giorni di tempo: 🔍
Tempo di esposizione: 🔍

Sequenza temporaleinfo

15/06/2018 🔍
22/06/2018 +7 giorni 🔍
26/06/2018 +3 giorni 🔍
26/06/2018 +0 giorni 🔍
27/06/2018 +1 giorni 🔍
15/08/2018 +49 giorni 🔍
16/08/2018 +1 giorni 🔍
29/03/2023 +1686 giorni 🔍

Fontiinfo

Advisory: RHSA-2018:3466
Stato: Non definito

CVE: CVE-2018-1000544 (🔍)

Voceinfo

Data di creazione: 27/06/2018 10:06
Aggiornamenti: 29/03/2023 08:15
I cambiamenti: 27/06/2018 10:06 (69), 22/02/2020 14:30 (3), 29/03/2023 08:15 (4)
Completa: 🔍

Discussione

Ancora nessun commento. Le Lingue: it + en.

Effettua il login per commentare.

Want to stay up to date on a daily basis?

Enable the mail alert feature now!