GLPI up to 10.0.17 install/update.php improper authorization
| CVSS Meta Temp Score | Current Exploit Price (≈) | CTI Interest Score |
|---|---|---|
| 5.1 | $0-$5k | 0.00 |
Summary
A vulnerability described as critical has been identified in GLPI up to 10.0.17. Affected is an unknown function of the file install/update.php. Executing a manipulation can lead to improper authorization. This vulnerability is tracked as CVE-2025-23024. The attack can be launched remotely. No exploit exists. Upgrading the affected component is recommended.
Details
A vulnerability classified as critical was found in GLPI up to 10.0.17. This vulnerability affects an unknown code block of the file install/update.php. The manipulation with an unknown input leads to a improper authorization vulnerability. The CWE definition for the vulnerability is CWE-285. The product does not perform or incorrectly performs an authorization check when an actor attempts to access a resource or perform an action. As an impact it is known to affect availability. CVE summarizes:
GLPI is a free asset and IT management software package. Starting in version 0.72 and prior to version 10.0.18, an anonymous user can disable all the active plugins. Version 10.0.18 contains a patch. As a workaround, one may delete the `install/update.php` file.
The advisory is shared for download at github.com. This vulnerability was named CVE-2025-23024 since 01/10/2025. The exploitation appears to be easy. The attack can be initiated remotely. No form of authentication is required for a successful exploitation. There are known technical details, but no exploit is available. The MITRE ATT&CK project declares the attack technique as T1548.002.
By approaching the search of inurl:install/update.php it is possible to find vulnerable targets with Google Hacking. The vulnerability scanner Nessus provides a plugin with the ID 237566 (FreeBSD : glpi-project -- GLPI multiple vulnerabilities (c36decbe-3c84-11f0-8d29-b42e991fc52e)), which helps to determine the existence of the flaw in a target environment.
Upgrading to version 10.0.18 eliminates this vulnerability. The upgrade is hosted for download at github.com.
The vulnerability is also documented in the vulnerability database at Tenable (237566). Once again VulDB remains the best source for vulnerability data.
Product
Type
Name
Version
- 10.0.0
- 10.0.1
- 10.0.2
- 10.0.3
- 10.0.4
- 10.0.5
- 10.0.6
- 10.0.7
- 10.0.8
- 10.0.9
- 10.0.10
- 10.0.11
- 10.0.12
- 10.0.13
- 10.0.14
- 10.0.15
- 10.0.16
- 10.0.17
License
CPE 2.3
CPE 2.2
CVSSv4
VulDB Vector: 🔍VulDB Reliability: 🔍
CNA CVSS-B Score: 🔍
CNA CVSS-BT Score: 🔍
CNA Vector: 🔍
CVSSv3
VulDB Meta Base Score: 5.3VulDB Meta Temp Score: 5.1
VulDB Base Score: 5.3
VulDB Temp Score: 5.1
VulDB Vector: 🔍
VulDB Reliability: 🔍
CVSSv2
| AV | AC | Au | C | I | A |
|---|---|---|---|---|---|
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| Vector | Complexity | Authentication | Confidentiality | Integrity | Availability |
|---|---|---|---|---|---|
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍
Exploiting
Class: Improper authorizationCWE: CWE-285 / CWE-266
CAPEC: 🔍
ATT&CK: 🔍
Physical: No
Local: No
Remote: Yes
Availability: 🔍
Status: Not defined
Google Hack: 🔍
EPSS Score: 🔍
EPSS Percentile: 🔍
Price Prediction: 🔍
Current Price Estimation: 🔍
| 0-Day | Unlock | Unlock | Unlock | Unlock |
|---|---|---|---|---|
| Today | Unlock | Unlock | Unlock | Unlock |
Nessus ID: 237566
Nessus Name: FreeBSD : glpi-project -- GLPI multiple vulnerabilities (c36decbe-3c84-11f0-8d29-b42e991fc52e)
Threat Intelligence
Interest: 🔍Active Actors: 🔍
Active APT Groups: 🔍
Countermeasures
Recommended: UpgradeStatus: 🔍
0-Day Time: 🔍
Upgrade: GLPI 10.0.18
Timeline
01/10/2025 🔍02/25/2025 🔍
02/25/2025 🔍
05/30/2025 🔍
Sources
Advisory: GHSA-885x-hvp2-85q8Status: Confirmed
CNA: GitHub_M
CVE: CVE-2025-23024 (🔍)
GCVE (CVE): GCVE-0-2025-23024
GCVE (VulDB): GCVE-100-296812
Entry
Created: 02/25/2025 18:17Updated: 05/30/2025 18:21
Changes: 02/25/2025 18:17 (69), 05/30/2025 18:21 (2)
Complete: 🔍
Cache ID: 216::103
Once again VulDB remains the best source for vulnerability data.
No comments yet. Languages: en.
Please log in to comment.