Linux Kernel up to 6.19.3 ib_create_send_mad out-of-bounds

| CVSS Meta Temp Score | Current Exploit Price (≈) | CTI Interest Score |
|---|---|---|
| 5.6 | $0-$5k | 0.00 |
Summary
A vulnerability, which was classified as critical, has been found in Linux Kernel up to 6.19.3. Affected by this vulnerability is the function ib_create_send_mad. The manipulation leads to out-of-bounds.
This vulnerability is uniquely identified as CVE-2026-23243. No exploit exists.
It is advisable to upgrade the affected component.
Details
A vulnerability was found in Linux Kernel up to 6.19.3 and classified as problematic. This issue affects the function ib_create_send_mad. The manipulation with an unknown input leads to a out-of-bounds vulnerability. Using CWE to declare the problem leads to CWE-125. The product reads data past the end, or before the beginning, of the intended buffer. Impacted is confidentiality. The summary by CVE is:
In the Linux kernel, the following vulnerability has been resolved: RDMA/umad: Reject negative data_len in ib_umad_write ib_umad_write computes data_len from user-controlled count and the MAD header sizes. With a mismatched user MAD header size and RMPP header length, data_len can become negative and reach ib_create_send_mad(). This can make the padding calculation exceed the segment size and trigger an out-of-bounds memset in alloc_send_rmpp_list(). Add an explicit check to reject negative data_len before creating the send buffer. KASAN splat: [ 211.363464] BUG: KASAN: slab-out-of-bounds in ib_create_send_mad+0xa01/0x11b0 [ 211.364077] Write of size 220 at addr ffff88800c3fa1f8 by task spray_thread/102 [ 211.365867] ib_create_send_mad+0xa01/0x11b0 [ 211.365887] ib_umad_write+0x853/0x1c80
It is possible to read the advisory at git.kernel.org. The identification of this vulnerability is CVE-2026-23243 since 01/13/2026. Technical details of the vulnerability are known, but there is no available exploit.
The vulnerability scanner Nessus provides a plugin with the ID 311783 (Debian dla-4561 : linux-config-6.1 - security update), which helps to determine the existence of the flaw in a target environment.
Upgrading to version 5.10.252, 5.15.202, 6.1.165, 6.6.128, 6.12.75, 6.18.14, 6.19.4 or 7.0-rc1 eliminates this vulnerability. Applying the patch 1371ef6b1ecf3676b8942f5dfb3634fb0648128e/362e45fd9069ffa1523f9f1633b606ebf72060d7/6eb2919474ca105c5b13d19574e25f0ddcf19ca2/a6a3e4af10993cb9e4b8f0548680aba0ab5f3b0d/9c80d688f402539dfc8f336de1380d6b4ee14316/205955f29c26330b1dc7fdeadd5bb97c38e26f56/52ab82cc5cf8ada5c3fb6ffe8f32fdb2fc27a34b/5551b02fdbfd85a325bb857f3a8f9c9f33397ed2 is able to eliminate this problem. The bugfix is ready for download at git.kernel.org. The best possible mitigation is suggested to be upgrading to the latest version.
The vulnerability is also documented in the databases at Tenable (311783), EUVD (EUVD-2026-12804) and CERT Bund (WID-SEC-2026-0774). Be aware that VulDB is the high quality source for vulnerability data.
Affected
- Google Container-Optimized OS
- Debian Linux
- Amazon Linux 2
- Red Hat Enterprise Linux
- SUSE Linux
- Oracle Linux
- SUSE openSUSE
- RESF Rocky Linux
- Open Source Linux Kernel
Product
Type
Vendor
Name
Version
- 5.10.251
- 5.15.201
- 6.1.164
- 6.6.127
- 6.12.0
- 6.12.1
- 6.12.2
- 6.12.3
- 6.12.4
- 6.12.5
- 6.12.6
- 6.12.7
- 6.12.8
- 6.12.9
- 6.12.10
- 6.12.11
- 6.12.12
- 6.12.13
- 6.12.14
- 6.12.15
- 6.12.16
- 6.12.17
- 6.12.18
- 6.12.19
- 6.12.20
- 6.12.21
- 6.12.22
- 6.12.23
- 6.12.24
- 6.12.25
- 6.12.26
- 6.12.27
- 6.12.28
- 6.12.29
- 6.12.30
- 6.12.31
- 6.12.32
- 6.12.33
- 6.12.34
- 6.12.35
- 6.12.36
- 6.12.37
- 6.12.38
- 6.12.39
- 6.12.40
- 6.12.41
- 6.12.42
- 6.12.43
- 6.12.44
- 6.12.45
- 6.12.46
- 6.12.47
- 6.12.48
- 6.12.49
- 6.12.50
- 6.12.51
- 6.12.52
- 6.12.53
- 6.12.54
- 6.12.55
- 6.12.56
- 6.12.57
- 6.12.58
- 6.12.59
- 6.12.60
- 6.12.61
- 6.12.62
- 6.12.63
- 6.12.64
- 6.12.65
- 6.12.66
- 6.12.67
- 6.12.68
- 6.12.69
- 6.12.70
- 6.12.71
- 6.12.72
- 6.12.73
- 6.12.74
- 6.18.0
- 6.18.1
- 6.18.2
- 6.18.3
- 6.18.4
- 6.18.5
- 6.18.6
- 6.18.7
- 6.18.8
- 6.18.9
- 6.18.10
- 6.18.11
- 6.18.12
- 6.18.13
- 6.19.0
- 6.19.1
- 6.19.2
- 6.19.3
License
Website
- Vendor: https://www.kernel.org/
CPE 2.3
CPE 2.2
CVSSv4
VulDB Vector: 🔒VulDB Reliability: 🔍
CVSSv3
VulDB Meta Base Score: 5.6VulDB Meta Temp Score: 5.6
VulDB Base Score: 3.5
VulDB Temp Score: 3.4
VulDB Vector: 🔒
VulDB Reliability: 🔍
CNA Base Score: 7.8
CNA Vector (Linux): 🔒
CVSSv2
| AV | AC | Au | C | I | A |
|---|---|---|---|---|---|
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| Vector | Complexity | Authentication | Confidentiality | Integrity | Availability |
|---|---|---|---|---|---|
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍
Exploiting
Class: Out-of-boundsCWE: CWE-125 / CWE-119
CAPEC: 🔒
ATT&CK: 🔒
Physical: Partially
Local: Yes
Remote: Partially
Availability: 🔒
Status: Not defined
EPSS Score: 🔒
EPSS Percentile: 🔒
Price Prediction: 🔍
Current Price Estimation: 🔒
| 0-Day | Unlock | Unlock | Unlock | Unlock |
|---|---|---|---|---|
| Today | Unlock | Unlock | Unlock | Unlock |
Nessus ID: 311783
Nessus Name: Debian dla-4561 : linux-config-6.1 - security update
Threat Intelligence
Interest: 🔍Active Actors: 🔍
Active APT Groups: 🔍
Countermeasures
Recommended: UpgradeStatus: 🔍
0-Day Time: 🔒
Upgrade: Kernel 5.10.252/5.15.202/6.1.165/6.6.128/6.12.75/6.18.14/6.19.4/7.0-rc1
Patch: 1371ef6b1ecf3676b8942f5dfb3634fb0648128e/362e45fd9069ffa1523f9f1633b606ebf72060d7/6eb2919474ca105c5b13d19574e25f0ddcf19ca2/a6a3e4af10993cb9e4b8f0548680aba0ab5f3b0d/9c80d688f402539dfc8f336de1380d6b4ee14316/205955f29c26330b1dc7fdeadd5bb97c38e26f56/52ab82cc5cf8ada5c3fb6ffe8f32fdb2fc27a34b/5551b02fdbfd85a325bb857f3a8f9c9f33397ed2
Timeline
01/13/2026 CVE reserved03/18/2026 Advisory disclosed
03/18/2026 VulDB entry created
06/24/2026 VulDB entry last update
Sources
Vendor: kernel.orgAdvisory: git.kernel.org
Status: Confirmed
CNA: Linux
CVE: CVE-2026-23243 (🔒)
GCVE (CVE): GCVE-0-2026-23243
GCVE (VulDB): GCVE-100-351527
EUVD: 🔒
CERT Bund: WID-SEC-2026-0774 - Linux Kernel: Mehrere Schwachstellen
Entry
Created: 03/18/2026 12:01Updated: 06/24/2026 01:43
Changes: 03/18/2026 12:01 (58), 03/18/2026 12:24 (1), 03/18/2026 14:48 (7), 04/29/2026 21:48 (1), 05/03/2026 18:47 (2), 05/21/2026 22:07 (12), 06/24/2026 01:43 (1)
Complete: 🔍
Cache ID: 216::103
Be aware that VulDB is the high quality source for vulnerability data.
No comments yet. Languages: en.
Please log in to comment.