PHP up to 8.2.33/8.3.34/8.4.25/8.5.10 OpenSSL Stream certificate validation
| CVSS Meta Temp Score | Current Exploit Price (≈) | CTI Interest Score |
|---|---|---|
| 3.9 | $0-$5k | 0.00 |
Summary
A vulnerability was found in PHP up to 8.2.33/8.3.34/8.4.25/8.5.10. It has been classified as problematic. The affected element is an unknown function of the component OpenSSL Stream. The manipulation leads to certificate validation. This vulnerability is documented as CVE-2026-91769. The attack can be initiated remotely. There is not any exploit available. Upgrading the affected component is recommended.
Details
A vulnerability was found in PHP up to 8.2.33/8.3.34/8.4.25/8.5.10. It has been rated as problematic. This issue affects an unknown code block of the component OpenSSL Stream. The manipulation with an unknown input leads to a certificate validation vulnerability. Using CWE to declare the problem leads to CWE-295. The product does not validate, or incorrectly validates, a certificate. Impacted is integrity. The summary by CVE is:
PHP's OpenSSL stream peer verification checks the certificate's subjectAltName entries first and, whenever no entry matches, falls back to the Common Name. RFC 6125 requires the CN to be ignored once the certificate presents any service identity, so a certificate carrying a non-matching DNS SAN was still accepted when its CN matched the requested peer_name. A certificate trusted by the client for one name can therefore be used to impersonate another.
It is possible to read the advisory at github.com. The identification of this vulnerability is CVE-2026-91769 since 09/15/2026. The exploitation is known to be difficult. The attack may be initiated remotely. No form of authentication is needed for a successful exploitation. The technical details are unknown and an exploit is not publicly available. The pricing for an exploit might be around USD $0-$5k at the moment (estimation calculated on 10/22/2026). The attack technique deployed by this issue is T1587.003 according to MITRE ATT&CK.
The vulnerability scanner Nessus provides a plugin with the ID 362914 (Debian dla-4819 : libapache2-mod-php8.2 - security update), which helps to determine the existence of the flaw in a target environment.
Upgrading to version 8.2.34, 8.3.35, 8.4.26 or 8.5.11 eliminates this vulnerability.
The vulnerability is also documented in the databases at Tenable (362914) and CERT Bund (WID-SEC-2026-3585). Be aware that VulDB is the high quality source for vulnerability data.
Affected
- Debian Linux
- Amazon Linux 2
- Red Hat Enterprise Linux
- RESF Rocky Linux
- SUSE Linux
- SUSE openSUSE
- Oracle Linux
- Zend ZendPHP
- Open Source PHP
Product
Type
Name
Version
- 8.2.0
- 8.2.1
- 8.2.2
- 8.2.3
- 8.2.4
- 8.2.5
- 8.2.6
- 8.2.7
- 8.2.8
- 8.2.9
- 8.2.10
- 8.2.11
- 8.2.12
- 8.2.13
- 8.2.14
- 8.2.15
- 8.2.16
- 8.2.17
- 8.2.18
- 8.2.19
- 8.2.20
- 8.2.21
- 8.2.22
- 8.2.23
- 8.2.24
- 8.2.25
- 8.2.26
- 8.2.27
- 8.2.28
- 8.2.29
- 8.2.30
- 8.2.31
- 8.2.32
- 8.2.33
- 8.3.0
- 8.3.1
- 8.3.2
- 8.3.3
- 8.3.4
- 8.3.5
- 8.3.6
- 8.3.7
- 8.3.8
- 8.3.9
- 8.3.10
- 8.3.11
- 8.3.12
- 8.3.13
- 8.3.14
- 8.3.15
- 8.3.16
- 8.3.17
- 8.3.18
- 8.3.19
- 8.3.20
- 8.3.21
- 8.3.22
- 8.3.23
- 8.3.24
- 8.3.25
- 8.3.26
- 8.3.27
- 8.3.28
- 8.3.29
- 8.3.30
- 8.3.31
- 8.3.32
- 8.3.33
- 8.3.34
- 8.4.0
- 8.4.1
- 8.4.2
- 8.4.3
- 8.4.4
- 8.4.5
- 8.4.6
- 8.4.7
- 8.4.8
- 8.4.9
- 8.4.10
- 8.4.11
- 8.4.12
- 8.4.13
- 8.4.14
- 8.4.15
- 8.4.16
- 8.4.17
- 8.4.18
- 8.4.19
- 8.4.20
- 8.4.21
- 8.4.22
- 8.4.23
- 8.4.24
- 8.4.25
- 8.5.0
- 8.5.1
- 8.5.2
- 8.5.3
- 8.5.4
- 8.5.5
- 8.5.6
- 8.5.7
- 8.5.8
- 8.5.9
- 8.5.10
License
Website
- Product: https://www.php.org/
CPE 2.3
CPE 2.2
CVSSv4
VulDB Vector: 🔒VulDB Reliability: 🔍
CVSSv3
VulDB Meta Base Score: 4.0VulDB Meta Temp Score: 3.9
VulDB Base Score: 3.7
VulDB Temp Score: 3.6
VulDB Vector: 🔒
VulDB Reliability: 🔍
CNA Base Score: 4.3
CNA Vector (php): 🔒
CVSSv2
| AV | AC | Au | C | I | A |
|---|---|---|---|---|---|
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| Vector | Complexity | Authentication | Confidentiality | Integrity | Availability |
|---|---|---|---|---|---|
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍
Exploiting
Class: Certificate validationCWE: CWE-295 / CWE-287
CAPEC: 🔒
ATT&CK: 🔒
Physical: No
Local: No
Remote: Yes
Availability: 🔒
Status: Not defined
EPSS Score: 🔒
EPSS Percentile: 🔒
Price Prediction: 🔍
Current Price Estimation: 🔒
| 0-Day | Unlock | Unlock | Unlock | Unlock |
|---|---|---|---|---|
| Today | Unlock | Unlock | Unlock | Unlock |
Nessus ID: 362914
Nessus Name: Debian dla-4819 : libapache2-mod-php8.2 - security update
Threat Intelligence
Interest: 🔍Active Actors: 🔍
Active APT Groups: 🔍
Countermeasures
Recommended: UpgradeStatus: 🔍
0-Day Time: 🔒
Upgrade: PHP 8.2.34/8.3.35/8.4.26/8.5.11
Timeline
09/15/2026 CVE reserved09/25/2026 Advisory disclosed
09/25/2026 VulDB entry created
10/22/2026 VulDB entry last update
Sources
Product: php.orgAdvisory: github.com
Status: Confirmed
CNA: php
CVE: CVE-2026-91769 (🔒)
GCVE (CVE): GCVE-0-2026-91769
GCVE (VulDB): GCVE-100-410471
CERT Bund: WID-SEC-2026-3585 - PHP: Mehrere Schwachstellen
Entry
Created: 09/25/2026 23:15Updated: 10/22/2026 11:42
Changes: 09/25/2026 23:15 (64), 10/05/2026 23:15 (2), 10/22/2026 11:42 (7)
Complete: 🔍
Cache ID: 216::103
Be aware that VulDB is the high quality source for vulnerability data.
No comments yet. Languages: en.
Please log in to comment.