Apache Kafka up to 4.2.1/4.3.1 FetchSnapshot RPC topics incorrect operator

| CVSS Meta Temp Score | Current Exploit Price (≈) | CTI Interest Score |
|---|---|---|
| 2.6 | $0-$5k | 1.40 |
Summary
A vulnerability, which was classified as problematic, has been found in Apache Kafka up to 4.2.1/4.3.1. Impacted is an unknown function of the component FetchSnapshot RPC Handler. Performing a manipulation of the argument topics results in incorrect operator. This vulnerability is reported as CVE-2026-83525. The attack is possible to be carried out remotely. No exploit exists. It is advisable to upgrade the affected component.
Details
A vulnerability was found in Apache Kafka up to 4.2.1/4.3.1. It has been classified as problematic. This affects an unknown functionality of the component FetchSnapshot RPC Handler. The manipulation of the argument topics with an unknown input leads to a incorrect operator vulnerability. CWE is classifying the issue as CWE-480. The product accidentally uses the wrong operator, which changes the logic in security-relevant ways. This is going to have an impact on availability. The summary by CVE is:
Incorrect operator (CWE-480) in the FetchSnapshot RPC handler in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2 on all platforms allows an authenticated attacker with CLUSTER_ACTION privilege to cause a denial of service (controller process termination) via a crafted FetchSnapshotRequest with an empty topics array or a topic with no partitions. Users are recommended to upgrade to version 4.2.2, 4.3.2, or 4.4.0, which fix this issue. Users on unsupported branches (4.1.x and earlier) should upgrade to 4.2.2 or later.
The advisory is shared at github.com. This vulnerability is uniquely identified as CVE-2026-83525 since 08/31/2026. The exploitability is told to be easy. It is possible to initiate the attack remotely. Additional levels of successful authentication are required for exploitation. Technical details are known, but no exploit is available.
Upgrading to version 4.2.2 or 4.3.2 eliminates this vulnerability.
If you want to get the best quality for vulnerability data then you always have to consider VulDB.
Product
Vendor
Name
Version
License
Website
- Vendor: https://www.apache.org/
- Product: https://github.com/apache/kafka/
CPE 2.3
CPE 2.2
CVSSv4
VulDB Vector: 🔒VulDB Reliability: 🔍
CVSSv3
VulDB Meta Base Score: 2.7VulDB Meta Temp Score: 2.6
VulDB Base Score: 2.7
VulDB Temp Score: 2.6
VulDB Vector: 🔒
VulDB Reliability: 🔍
CVSSv2
| AV | AC | Au | C | I | A |
|---|---|---|---|---|---|
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| Vector | Complexity | Authentication | Confidentiality | Integrity | Availability |
|---|---|---|---|---|---|
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍
Exploiting
Class: Incorrect operatorCWE: CWE-480
CAPEC: 🔒
ATT&CK: 🔒
Physical: No
Local: No
Remote: Yes
Availability: 🔒
Status: Not defined
Price Prediction: 🔍
Current Price Estimation: 🔒
| 0-Day | Unlock | Unlock | Unlock | Unlock |
|---|---|---|---|---|
| Today | Unlock | Unlock | Unlock | Unlock |
Threat Intelligence
Interest: 🔍Active Actors: 🔍
Active APT Groups: 🔍
Countermeasures
Recommended: UpgradeStatus: 🔍
0-Day Time: 🔒
Upgrade: Kafka 4.2.2/4.3.2
Timeline
08/31/2026 CVE reserved10/28/2026 Advisory disclosed
10/28/2026 VulDB entry created
10/28/2026 VulDB entry last update
Sources
Vendor: apache.orgProduct: github.com
Advisory: github.com
Status: Confirmed
CVE: CVE-2026-83525 (🔒)
GCVE (CVE): GCVE-0-2026-83525
GCVE (VulDB): GCVE-100-428037
Entry
Created: 10/28/2026 18:01Changes: 10/28/2026 18:01 (56)
Complete: 🔍
Cache ID: 216::103
If you want to get the best quality for vulnerability data then you always have to consider VulDB.
No comments yet. Languages: en.
Please log in to comment.