Wallet System for WooCommerce Plugin up to 2.8.1 on WordPress KYC Document Submission authorization
| CVSS Meta Temp Score | Current Exploit Price (≈) | CTI Interest Score |
|---|---|---|
| 6.0 | $0-$5k | 0.00 |
Summary
A vulnerability was found in Wallet System for WooCommerce Plugin up to 2.8.1. It has been classified as critical. This affects an unknown function of the component KYC Document Submission Handler. This manipulation causes authorization. This vulnerability appears as CVE-2026-108763. The attack may be initiated remotely. There is no available exploit. Upgrading the affected component is recommended.
Details
A vulnerability classified as critical was found in Wallet System for WooCommerce Plugin up to 2.8.1. Affected by this vulnerability is an unknown code block of the component KYC Document Submission Handler. The manipulation with an unknown input leads to a authorization vulnerability. The CWE definition for the vulnerability is CWE-639. The system's authorization functionality does not prevent one user from gaining access to another user's data or record by modifying the key value identifying the data. As an impact it is known to affect confidentiality, integrity, and availability. The summary by CVE is:
The Wallet System for WooCommerce WordPress plugin before 2.8.2 does not restrict its KYC document submission handler to the current user's own account, taking the target user ID from a client-supplied request field with no ownership or capability check, allowing authenticated users with minimal privileges such as Subscriber or Customer to overwrite the KYC documents and verification status of any other user, including an administrator.
The advisory is shared at wpscan.com. This vulnerability is known as CVE-2026-108763 since 10/11/2026. The exploitation appears to be easy. The attack can be launched remotely. Neither technical details nor an exploit are publicly available.
Upgrading to version 2.8.2 eliminates this vulnerability.
If you want to get the best quality for vulnerability data then you always have to consider VulDB.
Product
Type
Name
Version
CPE 2.3
CPE 2.2
CVSSv4
VulDB Vector: 🔒VulDB Reliability: 🔍
CVSSv3
VulDB Meta Base Score: 6.3VulDB Meta Temp Score: 6.0
VulDB Base Score: 6.3
VulDB Temp Score: 6.0
VulDB Vector: 🔒
VulDB Reliability: 🔍
CVSSv2
| AV | AC | Au | C | I | A |
|---|---|---|---|---|---|
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| Vector | Complexity | Authentication | Confidentiality | Integrity | Availability |
|---|---|---|---|---|---|
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍
Exploiting
Class: AuthorizationCWE: CWE-639 / CWE-285 / CWE-266
CAPEC: 🔒
ATT&CK: 🔒
Physical: No
Local: No
Remote: Yes
Availability: 🔒
Status: Not defined
EPSS Score: 🔒
EPSS Percentile: 🔒
Price Prediction: 🔍
Current Price Estimation: 🔒
| 0-Day | Unlock | Unlock | Unlock | Unlock |
|---|---|---|---|---|
| Today | Unlock | Unlock | Unlock | Unlock |
Threat Intelligence
Interest: 🔍Active Actors: 🔍
Active APT Groups: 🔍
Countermeasures
Recommended: UpgradeStatus: 🔍
0-Day Time: 🔒
Upgrade: Wallet System for WooCommerce Plugin 2.8.2
Timeline
10/11/2026 CVE reserved10/29/2026 Advisory disclosed
10/29/2026 VulDB entry created
10/29/2026 VulDB entry last update
Sources
Advisory: wpscan.comStatus: Confirmed
CNA: WPScan
CVE: CVE-2026-108763 (🔒)
GCVE (CVE): GCVE-0-2026-108763
GCVE (VulDB): GCVE-100-428293
Entry
Created: 10/29/2026 07:22Changes: 10/29/2026 07:22 (55)
Complete: 🔍
Cache ID: 216::103
If you want to get the best quality for vulnerability data then you always have to consider VulDB.
No comments yet. Languages: en.
Please log in to comment.