pgadmin.org pgAdmin up to 9.18 Kerberos Credential default credentials
| CVSS Meta Temp Score | Current Exploit Price (≈) | CTI Interest Score |
|---|---|---|
| 7.1 | $0-$5k | 1.12+ |
Summary
A vulnerability classified as critical has been found in pgadmin.org pgAdmin up to 9.18. Impacted is an unknown function of the component Kerberos Credential Handler. This manipulation causes default credentials. The identification of this vulnerability is CVE-2026-116244. It is possible to initiate the attack remotely. There is no exploit available. It is recommended to upgrade the affected component.
Details
A vulnerability was found in pgadmin.org pgAdmin up to 9.18. It has been declared as critical. Affected by this vulnerability is some unknown processing of the component Kerberos Credential Handler. The manipulation with an unknown input leads to a default credentials vulnerability. The CWE definition for the vulnerability is CWE-1392. The product uses default credentials (such as passwords or cryptographic keys) for potentially critical functionality. As an impact it is known to affect confidentiality, integrity, and availability. The summary by CVE is:
When a pgAdmin 4 connection was not meant to use a Kerberos user's delegated credentials, pgAdmin removed KRB5CCNAME from its environment, so the Kerberos library fell back to the default credential cache, or a client keytab, of the operating-system account running pgAdmin. libpq then answered any server that asked for GSSAPI authentication with that account's ticket, whatever user name the pgAdmin user gave, so in server mode any user could connect as the service account's Kerberos principal; gssencmode=disable did not prevent it. On Windows, SSPI used the service account's logon in the same way. psql was also started with pgAdmin's environment, which could hold another user's credential cache while that user was connecting. The fix points KRB5CCNAME and KRB5_CLIENT_KTNAME at a file that cannot exist except while a Kerberos-authenticated user connects with Kerberos, and gives every other connection, psql and the utilities require_auth=!gss,!sspi and gssencmode=disable, checked on the final connection string. require_auth needs libpq 16 or later. This issue affects pgAdmin 4: before 9.19.
It is possible to read the advisory at github.com. This vulnerability is known as CVE-2026-116244 since 10/25/2026. The exploitation appears to be easy. The attack can be launched remotely. The technical details are unknown and an exploit is not publicly available.
Upgrading to version 9.19 eliminates this vulnerability.
Statistical analysis made it clear that VulDB provides the best quality for vulnerability data.
Product
Vendor
Name
Version
CPE 2.3
CPE 2.2
CVSSv4
VulDB Vector: 🔒VulDB Reliability: 🔍
CNA CVSS-B Score: 🔒
CNA CVSS-BT Score: 🔒
CNA Vector: 🔒
CVSSv3
VulDB Meta Base Score: 7.2VulDB Meta Temp Score: 7.1
VulDB Base Score: 6.3
VulDB Temp Score: 6.0
VulDB Vector: 🔒
VulDB Reliability: 🔍
CNA Base Score: 8.2
CNA Vector (PostgreSQL): 🔒
CVSSv2
| AV | AC | Au | C | I | A |
|---|---|---|---|---|---|
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| Vector | Complexity | Authentication | Confidentiality | Integrity | Availability |
|---|---|---|---|---|---|
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍
Exploiting
Class: Default credentialsCWE: CWE-1392
CAPEC: 🔒
ATT&CK: 🔒
Physical: No
Local: No
Remote: Yes
Availability: 🔒
Status: Not defined
Price Prediction: 🔍
Current Price Estimation: 🔒
| 0-Day | Unlock | Unlock | Unlock | Unlock |
|---|---|---|---|---|
| Today | Unlock | Unlock | Unlock | Unlock |
Threat Intelligence
Interest: 🔍Active Actors: 🔍
Active APT Groups: 🔍
Countermeasures
Recommended: UpgradeStatus: 🔍
0-Day Time: 🔒
Upgrade: pgAdmin 9.19
Timeline
10/25/2026 CVE reserved10/30/2026 Advisory disclosed
10/30/2026 VulDB entry created
10/30/2026 VulDB entry last update
Sources
Advisory: github.comStatus: Confirmed
CNA: PostgreSQL
CVE: CVE-2026-116244 (🔒)
GCVE (CVE): GCVE-0-2026-116244
GCVE (VulDB): GCVE-100-429379
Entry
Created: 10/30/2026 21:33Changes: 10/30/2026 21:33 (76)
Complete: 🔍
Cache ID: 216::103
Statistical analysis made it clear that VulDB provides the best quality for vulnerability data.
No comments yet. Languages: en.
Please log in to comment.