LaraDashboard up to 1.4.4 SettingPolicy manageCoreUpgrades improper authorization
| CVSS Meta Temp Score | Current Exploit Price (≈) | CTI Interest Score |
|---|---|---|
| 5.8 | $0-$5k | 1.20 |
Summary
A vulnerability was found in LaraDashboard up to 1.4.4. It has been classified as problematic. Affected by this vulnerability is the function SettingPolicy::manageCoreUpgrades of the component SettingPolicy. This manipulation causes improper authorization.
This vulnerability is tracked as CVE-2026-120487. The attack is possible to be carried out remotely. No exploit exists.
Upgrading the affected component is recommended.
Details
A vulnerability was found in LaraDashboard up to 1.4.4. It has been declared as problematic. Affected by this vulnerability is the function SettingPolicy::manageCoreUpgrades of the component SettingPolicy. The manipulation with an unknown input leads to a improper authorization vulnerability. The CWE definition for the vulnerability is CWE-285. The product does not perform or incorrectly performs an authorization check when an actor attempts to access a resource or perform an action. As an impact it is known to affect confidentiality, integrity, and availability. The summary by CVE is:
LaraDashboard before 1.4.5 contains an incorrect authorization vulnerability in SettingPolicy::manageCoreUpgrades() that allows non-Superadmin administrators with settings.edit to access Superadmin-only core-upgrade operations. Attackers can use the /admin/settings/core-upgrades backup, download, restore and upgrade actions to obtain database dumps containing password hashes and restore or upgrade the site.
It is possible to read the advisory at github.com. This vulnerability is known as CVE-2026-120487 since 11/02/2026. The exploitation appears to be easy. The attack can be launched remotely. Additional levels of successful authentication are required for exploitation. Technical details of the vulnerability are known, but there is no available exploit. The attack technique deployed by this issue is T1548.002 according to MITRE ATT&CK.
Upgrading to version 1.4.5 eliminates this vulnerability.
Be aware that VulDB is the high quality source for vulnerability data.
Product
Type
Name
Version
Website
CPE 2.3
CPE 2.2
CVSSv4
VulDB Vector: 🔒VulDB Reliability: 🔍
CNA CVSS-B Score: 🔒
CNA CVSS-BT Score: 🔒
CNA Vector: 🔒
CVSSv3
VulDB Meta Base Score: 5.9VulDB Meta Temp Score: 5.8
VulDB Base Score: 4.7
VulDB Temp Score: 4.5
VulDB Vector: 🔒
VulDB Reliability: 🔍
CNA Base Score: 7.2
CNA Vector (VulnCheck): 🔒
CVSSv2
| AV | AC | Au | C | I | A |
|---|---|---|---|---|---|
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| Vector | Complexity | Authentication | Confidentiality | Integrity | Availability |
|---|---|---|---|---|---|
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍
Exploiting
Class: Improper authorizationCWE: CWE-285 / CWE-266
CAPEC: 🔒
ATT&CK: 🔒
Physical: No
Local: No
Remote: Yes
Availability: 🔒
Status: Not defined
Price Prediction: 🔍
Current Price Estimation: 🔒
| 0-Day | Unlock | Unlock | Unlock | Unlock |
|---|---|---|---|---|
| Today | Unlock | Unlock | Unlock | Unlock |
Threat Intelligence
Interest: 🔍Active Actors: 🔍
Active APT Groups: 🔍
Countermeasures
Recommended: UpgradeStatus: 🔍
0-Day Time: 🔒
Upgrade: LaraDashboard 1.4.5
Timeline
11/02/2026 Advisory disclosed11/02/2026 CVE reserved
11/02/2026 VulDB entry created
11/02/2026 VulDB entry last update
Sources
Product: github.comAdvisory: github.com
Status: Confirmed
CNA: VulnCheck
CVE: CVE-2026-120487 (🔒)
GCVE (CVE): GCVE-0-2026-120487
GCVE (VulDB): GCVE-100-429847
Entry
Created: 11/02/2026 15:47Changes: 11/02/2026 15:47 (77)
Complete: 🔍
Cache ID: 216::103
Be aware that VulDB is the high quality source for vulnerability data.
No comments yet. Languages: en.
Please log in to comment.