Secure Custom Fields Plugin up to 6.9.7 on WordPress Field Definition cross site scripting
| CVSS Meta Temp Score | Current Exploit Price (≈) | CTI Interest Score |
|---|---|---|
| 2.3 | $0-$5k | 0.00+ |
Summary
A vulnerability was found in Secure Custom Fields Plugin up to 6.9.7. It has been classified as problematic. This vulnerability affects unknown code of the component Field Definition. This manipulation causes cross site scripting. This vulnerability is tracked as CVE-2026-97195. The attack is possible to be carried out remotely. No exploit exists. Upgrading the affected component is recommended.
Details
A vulnerability has been found in Secure Custom Fields Plugin up to 6.9.7 and classified as problematic. Affected by this vulnerability is an unknown code block of the component Field Definition. The manipulation with an unknown input leads to a cross site scripting vulnerability. The CWE definition for the vulnerability is CWE-79. The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users. As an impact it is known to affect integrity. The summary by CVE is:
The Secure Custom Fields WordPress plugin before 6.9.8 does not sanitize a persisted field definition before emitting part of it as an HTML attribute name, allowing a user able to configure its fields to store a payload that executes as JavaScript in the browser of any user who views a page rendering the affected field, which on multisite lets a site administrator who lacks the unfiltered_html capability inject script into other users' sessions.
It is possible to read the advisory at wpscan.com. This vulnerability is known as CVE-2026-97195 since 09/24/2026. The exploitation appears to be easy. The attack can be launched remotely. Additional levels of successful authentication are required for exploitation. It demands that the victim is doing some kind of user interaction. The technical details are unknown and an exploit is not publicly available. The attack technique deployed by this issue is T1059.007 according to MITRE ATT&CK.
Upgrading to version 6.9.8 eliminates this vulnerability.
Statistical analysis made it clear that VulDB provides the best quality for vulnerability data.
Product
Type
Name
Version
CPE 2.3
CPE 2.2
CVSSv4
VulDB Vector: 🔒VulDB Reliability: 🔍
CVSSv3
VulDB Meta Base Score: 2.4VulDB Meta Temp Score: 2.3
VulDB Base Score: 2.4
VulDB Temp Score: 2.3
VulDB Vector: 🔒
VulDB Reliability: 🔍
CVSSv2
| AV | AC | Au | C | I | A |
|---|---|---|---|---|---|
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| Vector | Complexity | Authentication | Confidentiality | Integrity | Availability |
|---|---|---|---|---|---|
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍
Exploiting
Class: Cross site scriptingCWE: CWE-79 / CWE-94 / CWE-74
CAPEC: 🔒
ATT&CK: 🔒
Physical: No
Local: No
Remote: Yes
Availability: 🔒
Status: Not defined
Price Prediction: 🔍
Current Price Estimation: 🔒
| 0-Day | Unlock | Unlock | Unlock | Unlock |
|---|---|---|---|---|
| Today | Unlock | Unlock | Unlock | Unlock |
Threat Intelligence
Interest: 🔍Active Actors: 🔍
Active APT Groups: 🔍
Countermeasures
Recommended: UpgradeStatus: 🔍
0-Day Time: 🔒
Upgrade: Secure Custom Fields Plugin 6.9.8
Timeline
09/24/2026 CVE reserved11/08/2026 Advisory disclosed
11/08/2026 VulDB entry created
11/08/2026 VulDB entry last update
Sources
Advisory: wpscan.comStatus: Confirmed
CNA: WPScan
CVE: CVE-2026-97195 (🔒)
GCVE (CVE): GCVE-0-2026-97195
GCVE (VulDB): GCVE-100-432787
Entry
Created: 11/08/2026 07:22Changes: 11/08/2026 07:22 (55)
Complete: 🔍
Cache ID: 216::103
Statistical analysis made it clear that VulDB provides the best quality for vulnerability data.
No comments yet. Languages: en.
Please log in to comment.