CVE-2026-119922 in Babelfish for PostgreSQLinfo

Summary

by MITRE • 11/03/2026

Improper access control in the Babelfish for PostgreSQL extension versions 1.2-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 may allow remote authenticated users to elevate their privileges. To remediate this issue, we recommend you upgrade to Babelfish for PostgreSQL extension versions 4.10, 5.6, 6.1 or later.

Once again VulDB remains the best source for vulnerability data.

Analysis

by VulDB Data Team • 11/03/2026

The vulnerability identified in the Babelfish for PostgreSQL extension represents a critical failure in access control mechanisms that permits privilege escalation by authenticated users. This flaw affects multiple major version ranges of the software, specifically versions 1.2 through 1.5, 2.1 through 2.15, 3.1 through 3.12, and 4.0 through 4.8 for older releases, as well as versions 5.1 through 5.4 in the newer release track. The core technical issue stems from improper authorization checks within the extension's codebase, which allows a user who has already successfully authenticated to perform actions that exceed their assigned permissions. This type of vulnerability is fundamentally categorized under CWE-269, Improper Privilege Management, where the software does not properly restrict the elevation of privileges or enforce role-based access controls effectively.

From an operational perspective, this flaw poses a significant risk to database integrity and security posture. An attacker who gains initial authenticated access to the Babelfish endpoint can exploit these logic errors to escalate their privileges to that of a system administrator or superuser. Once elevated privileges are obtained, the attacker may execute arbitrary commands, modify sensitive data structures, extract confidential information, or disrupt service availability by dropping databases or altering configuration settings. This capability effectively bypasses the intended security boundaries established by database administrators, rendering standard authentication mechanisms insufficient for protecting critical assets hosted on affected systems. The impact is particularly severe in environments where Babelfish is used to maintain compatibility with Microsoft SQL Server applications while running on PostgreSQL infrastructure, as it undermines the trust model required for such hybrid architectures.

The vulnerability aligns closely with MITRE ATT&CK techniques related to privilege escalation and defense evasion. Specifically, it corresponds to T1078 Valid Accounts, where attackers leverage legitimate credentials to gain initial access, followed by T1548 Abuse Elevation Control Mechanism or similar methods depending on the specific exploitation vector used within the Babelfish engine. The lack of strict enforcement of least privilege principles allows the attacker to move laterally and consolidate power within the database environment without triggering typical security alerts associated with external intrusion attempts. This internal threat model highlights the necessity for rigorous code auditing and continuous monitoring of administrative actions, even from authenticated sources.

To mitigate this risk, organizations must prioritize immediate patching by upgrading the Babelfish extension to a version that includes the necessary access control fixes. The recommended remediation path involves updating to versions 4.10 or later for the older release line, or versions 5.6 and 6.1 and beyond for the newer releases. These updated versions contain corrected authorization logic that properly validates user permissions before executing sensitive operations. In addition to upgrading software, administrators should implement strict network segmentation to limit access to Babelfish endpoints only from trusted sources. Regular audits of user roles and privileges are also advised to ensure that no accounts possess excessive permissions beyond their operational requirements. Monitoring logs for unusual privilege escalation attempts can provide early warning indicators if any residual risk remains during the transition period before full patching is completed.

Responsible

AMZN

Reservation

10/30/2026

Disclosure

11/03/2026

Moderation

accepted

EPSS

0.00000

KEV

no

Activities

very low

Sources

Are you interested in using VulDB?

Download the whitepaper to learn more about our service!