libdwarf 0.4.0 dwarf_global_formref_b Pufferüberlauf

CVSS Meta Temp ScoreAktueller Exploitpreis (≈)CTI Interest Score
5.3$0-$5k0.00

In libdwarf 0.4.0 (Programming Tool Software) wurde eine Schwachstelle entdeckt. Sie wurde als kritisch eingestuft. Hierbei betrifft es die Funktion dwarf_global_formref_b. Durch Beeinflussen mit einer unbekannten Eingabe kann eine Pufferüberlauf-Schwachstelle ausgenutzt werden. CWE definiert das Problem als CWE-122. Die genauen Auswirkungen eines erfolgreichen Angriffs sind bisher nicht bekannt. CVE fasst zusammen:

There is a heap-based buffer over-read in libdwarf 0.4.0. This issue is related to dwarf_global_formref_b.

Die Schwachstelle wurde am 24.06.2022 als 119 an die Öffentlichkeit getragen. Das Advisory kann von github.com heruntergeladen werden. Eine eindeutige Identifikation der Schwachstelle wird seit dem 22.06.2022 mit CVE-2022-34299 vorgenommen. Technische Details sind bekannt, ein verfügbarer Exploit hingegen nicht.

Die Schwachstelle lässt sich durch das Einspielen des Patches 7ef09e1fc9ba07653dd078edb2408631c7969162 beheben. Dieser kann von github.com bezogen werden.

Von weiterem Interesse können die folgenden Einträge sein: VDB-7566, VDB-104502, VDB-111071 und VDB-114237.

Produktinfo

Typ

Name

Version

Lizenz

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Zuverlässigkeit: 🔍

CVSSv3info

VulDB Meta Base Score: 5.5
VulDB Meta Temp Score: 5.3

VulDB Base Score: 5.5
VulDB Temp Score: 5.3
VulDB Vector: 🔍
VulDB Zuverlässigkeit: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VektorKomplexitätAuthentisierungVertraulichkeitIntegritätVerfügbarkeit
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Zuverlässigkeit: 🔍

Exploitinginfo

Klasse: Pufferüberlauf
CWE: CWE-122 / CWE-119
CAPEC: 🔍
ATT&CK: 🔍

Lokal: Nein
Remote: Teilweise

Verfügbarkeit: 🔍
Status: Nicht definiert

EPSS Score: 🔍
EPSS Percentile: 🔍

Preisentwicklung: 🔍
Aktuelle Preisschätzung: 🔍

0-Dayfreischaltenfreischaltenfreischaltenfreischalten
Heutefreischaltenfreischaltenfreischaltenfreischalten

Threat Intelligenceinfo

Interesse: 🔍
Aktive Akteure: 🔍
Aktive APT Gruppen: 🔍

Gegenmassnahmeninfo

Empfehlung: Patch
Status: 🔍

0-Day Time: 🔍

Patch: 7ef09e1fc9ba07653dd078edb2408631c7969162

Timelineinfo

22.06.2022 🔍
24.06.2022 +2 Tage 🔍
24.06.2022 +0 Tage 🔍
24.06.2022 +0 Tage 🔍

Quelleninfo

Advisory: 119
Status: Bestätigt

CVE: CVE-2022-34299 (🔍)
Siehe auch: 🔍

Eintraginfo

Erstellt: 24.06.2022 07:10
Anpassungen: 24.06.2022 07:10 (42)
Komplett: 🔍
Cache ID: 3:DD3:40

Diskussion

Bisher keine Kommentare. Sprachen: de + en.

Bitte loggen Sie sich ein, um kommentieren zu können.

Want to stay up to date on a daily basis?

Enable the mail alert feature now!