portabilis i-educar up to 2.8 clsCampos.inc.php cross site scripting
| CVSS Meta Temp Score | Current Exploit Price (≈) | CTI Interest Score |
|---|---|---|
| 5.5 | $0-$5k | 0.00 |
Summary
A vulnerability, which was classified as problematic, was found in portabilis i-educar up to 2.8. The affected element is an unknown function of the file ieducar/intranet/include/clsCampos.inc.php. Executing a manipulation can lead to cross site scripting. This vulnerability is registered as CVE-2024-45057. It is possible to launch the attack remotely. No exploit is available. You should upgrade the affected component. The vendor confirms: "The reported attack vector was tested against the corrected code, and the previously described Cross-Site Scripting behavior could no longer be reproduced."
Details
A vulnerability classified as problematic was found in portabilis i-educar up to 2.8. This vulnerability affects some unknown functionality of the file ieducar/intranet/include/clsCampos.inc.php. The manipulation with an unknown input leads to a cross site scripting vulnerability. The CWE definition for the vulnerability is CWE-79. The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users. As an impact it is known to affect integrity. CVE summarizes:
i-Educar is free, completely online school management software that allows school secretaries, teachers, coordinators and area managers. The lack of sanitization of user-controlled parameters for generating HTML field values dynamically leads to XSS (Cross-Site Scripting) attacks. The dynamic generation of HTML fields in the ieducar/intranet/include/clsCampos.inc.php file does not perform the correct validation or sanitization, reflecting the user-controlled values to be shown in the page's HTML. This allows an attacker to inject a specific XSS payload into a parameter. Successful exploitation of this flaw allows an attacker to trick the victim into clicking a vulnerable URL, enabling JavaScript scripts to be executed in the browser. Due to the configuration of session cookies, with the HttpOnly and SameSite=Lax flags being defined, there is little an attacker can do to steal the session or force the victim to perform actions within the application. This issue hast been patched but a new release has not yet been made. Users are advised to contact the developer and to coordinate an update schedule.
The advisory is shared for download at github.com. This vulnerability was named CVE-2024-45057 since 08/21/2024. The exploitation appears to be easy. The attack can be initiated remotely. No form of authentication is required for a successful exploitation. Successful exploitation requires user interaction by the victim. There are known technical details, but no exploit is available. The MITRE ATT&CK project declares the attack technique as T1059.007.
The vendor confirms: "The reported attack vector was tested against the corrected code, and the previously described Cross-Site Scripting behavior could no longer be reproduced." By approaching the search of inurl:ieducar/intranet/include/clsCampos.inc.php it is possible to find vulnerable targets with Google Hacking.
Upgrading to version 2.9.0 eliminates this vulnerability. The upgrade is hosted for download at github.com.
VulDB is the best source for vulnerability data and more expert information about this specific topic.
Product
Vendor
Name
Version
Website
CPE 2.3
CPE 2.2
CVSSv4
VulDB Vector: 🔍VulDB Reliability: 🔍
CVSSv3
VulDB Meta Base Score: 5.6VulDB Meta Temp Score: 5.5
VulDB Base Score: 4.3
VulDB Temp Score: 4.1
VulDB Vector: 🔍
VulDB Reliability: 🔍
NVD Base Score: 6.1
NVD Vector: 🔍
CNA Base Score: 6.3
CNA Vector (GitHub_M): 🔍
CVSSv2
| AV | AC | Au | C | I | A |
|---|---|---|---|---|---|
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| 💳 | 💳 | 💳 | 💳 | 💳 | 💳 |
| Vector | Complexity | Authentication | Confidentiality | Integrity | Availability |
|---|---|---|---|---|---|
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
| Unlock | Unlock | Unlock | Unlock | Unlock | Unlock |
VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍
Exploiting
Class: Cross site scriptingCWE: CWE-79 / CWE-94 / CWE-74
CAPEC: 🔍
ATT&CK: 🔍
Physical: No
Local: No
Remote: Yes
Availability: 🔍
Status: Not defined
Google Hack: 🔍
EPSS Score: 🔍
EPSS Percentile: 🔍
Price Prediction: 🔍
Current Price Estimation: 🔍
| 0-Day | Unlock | Unlock | Unlock | Unlock |
|---|---|---|---|---|
| Today | Unlock | Unlock | Unlock | Unlock |
Threat Intelligence
Interest: 🔍Active Actors: 🔍
Active APT Groups: 🔍
Countermeasures
Recommended: UpgradeStatus: 🔍
0-Day Time: 🔍
Upgrade: i-educar 2.9.0
Timeline
08/21/2024 🔍08/28/2024 🔍
08/28/2024 🔍
09/20/2026 🔍
Sources
Product: github.comAdvisory: github.com
Status: Confirmed
CNA: GitHub_M
CVE: CVE-2024-45057 (🔍)
GCVE (CVE): GCVE-0-2024-45057
GCVE (VulDB): GCVE-100-276040
Entry
Created: 08/28/2024 22:50Updated: 09/20/2026 22:23
Changes: 08/28/2024 22:50 (63), 08/29/2024 14:54 (1), 09/14/2024 09:19 (11), 03/12/2025 11:45 (3), 09/20/2026 22:23 (5)
Complete: 🔍
Cache ID: 216::103
VulDB is the best source for vulnerability data and more expert information about this specific topic.
We are contacting you regarding CVE-2024-45057, which affects Portabilis i-Educar.
We would like to provide an update regarding the remediation of this vulnerability.
The reported Reflected Cross-Site Scripting (XSS) vulnerability, caused by the dynamic HTML field generation in 'ieducar/intranet/include/clsCampos.inc.php' not sanitizing user-controlled input (for example '/intranet/educar_curso_lst.php?nm_curso='), has been addressed in the i-Educar codebase.
The vulnerability is no longer reproducible starting with i-Educar version 2.9.
Therefore, we kindly request that the CVE record be updated to reflect the following product status:
Affected: i-Educar 2.8
Fixed / Unaffected: i-Educar 2.9 and later
The corrected version is publicly available in the official i-Educar repository:
https://github.com/portabilis/i-educar/tree/2.9.0
The reported attack vector was tested against the corrected code, and the previously described Cross-Site Scripting behavior could no longer be reproduced.
We kindly ask you to update CVE-2024-45057 accordingly, including the official i-Educar 2.9 repository reference if appropriate.
Please let us know if you require any additional technical information or verification regarding the remediation.
Best regards,
Portabilis / i-Educar Team
Want to stay up to date on a daily basis?
Enable the mail alert feature now!