Juanpao JPShop up to 1.5.02 API ComboController.php actionIndex pic_url unrestricted upload

A vulnerability classified as critical has been found in Juanpao JPShop up to 1.5.02. This affects the function actionIndex of the file /api/controllers/admin/app/ComboController.php of the component API. The manipulation of the argument pic_url leads to unrestricted upload. The CWE definition for the vulnerability is CWE-434. The weakness was shared 02/06/2024. It is possible to read the advisory at note.zhaoj.in. This vulnerability is uniquely identified as CVE-2024-1260. It is possible to initiate the attack remotely. Technical details are available. Furthermore, there is an exploit available. The exploit has been disclosed to the public and may be used. The pricing for an exploit might be around USD $0-$5k at the moment. The attack technique deployed by this issue is T1608.002 according to MITRE ATT&CK. It is declared as proof-of-concept. The exploit is shared for download at note.zhaoj.in. We expect the 0-day to have been worth approximately $0-$5k. A possible mitigation has been published before and not just after the disclosure of the vulnerability.

Field02/06/2024 09:34 AM03/01/2024 08:15 AM03/01/2024 08:16 AM
vendorJuanpaoJuanpaoJuanpao
nameJPShopJPShopJPShop
version<=1.5.02<=1.5.02<=1.5.02
componentAPIAPIAPI
file/api/controllers/admin/app/ComboController.php/api/controllers/admin/app/ComboController.php/api/controllers/admin/app/ComboController.php
functionactionIndexactionIndexactionIndex
argumentpic_urlpic_urlpic_url
cwe434 (unrestricted upload)434 (unrestricted upload)434 (unrestricted upload)
cvss3_vuldb_avNNN
cvss3_vuldb_acLLL
cvss3_vuldb_uiNNN
cvss3_vuldb_sUUU
cvss3_vuldb_cLLL
cvss3_vuldb_iLLL
cvss3_vuldb_aLLL
cvss3_vuldb_ePPP
cvss3_vuldb_rcRRR
urlhttps://note.zhaoj.in/share/H73DuWdyifaIhttps://note.zhaoj.in/share/H73DuWdyifaIhttps://note.zhaoj.in/share/H73DuWdyifaI
availability111
publicity111
urlhttps://note.zhaoj.in/share/H73DuWdyifaIhttps://note.zhaoj.in/share/H73DuWdyifaIhttps://note.zhaoj.in/share/H73DuWdyifaI
cveCVE-2024-1260CVE-2024-1260CVE-2024-1260
responsibleVulDBVulDBVulDB
date1707174000 (02/06/2024)1707174000 (02/06/2024)1707174000 (02/06/2024)
cvss2_vuldb_avNNN
cvss2_vuldb_acLLL
cvss2_vuldb_ciPPP
cvss2_vuldb_iiPPP
cvss2_vuldb_aiPPP
cvss2_vuldb_ePOCPOCPOC
cvss2_vuldb_rcURURUR
cvss2_vuldb_auSSS
cvss2_vuldb_rlNDNDND
cvss3_vuldb_prLLL
cvss3_vuldb_rlXXX
cvss2_vuldb_basescore6.56.56.5
cvss2_vuldb_tempscore5.65.65.6
cvss3_vuldb_basescore6.36.36.3
cvss3_vuldb_tempscore5.75.75.7
cvss3_meta_basescore6.36.37.5
cvss3_meta_tempscore5.75.77.3
price_0day$0-$5k$0-$5k$0-$5k
cve_assigned1707174000 (02/06/2024)1707174000 (02/06/2024)
cve_nvd_summaryA vulnerability classified as critical has been found in Juanpao JPShop up to 1.5.02. This affects the function actionIndex of the file /api/controllers/admin/app/ComboController.php of the component API. The manipulation of the argument pic_url leads to unrestricted upload. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-252999.A vulnerability classified as critical has been found in Juanpao JPShop up to 1.5.02. This affects the function actionIndex of the file /api/controllers/admin/app/ComboController.php of the component API. The manipulation of the argument pic_url leads to unrestricted upload. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-252999.
cvss3_nvd_avN
cvss3_nvd_acL
cvss3_nvd_prN
cvss3_nvd_uiN
cvss3_nvd_sU
cvss3_nvd_cH
cvss3_nvd_iH
cvss3_nvd_aH
cvss2_nvd_avN
cvss2_nvd_acL
cvss2_nvd_auS
cvss2_nvd_ciP
cvss2_nvd_iiP
cvss2_nvd_aiP
cvss3_cna_avN
cvss3_cna_acL
cvss3_cna_prL
cvss3_cna_uiN
cvss3_cna_sU
cvss3_cna_cL
cvss3_cna_iL
cvss3_cna_aL
cve_cnaVulDB
cvss2_nvd_basescore6.5
cvss3_nvd_basescore9.8
cvss3_cna_basescore6.3

Do you know our Splunk app?

Download it now for free!