EasyCorp EasyAdmin up to 4.8.9 Autocomplete autocomplete.js item cross site scripting

A vulnerability was found in EasyCorp EasyAdmin up to 4.8.9. It has been declared as problematic. Affected by this vulnerability is the function Autocomplete of the file assets/js/autocomplete.js of the component Autocomplete. The manipulation of the argument item leads to cross site scripting. The CWE definition for the vulnerability is CWE-79. The weakness was presented 03/29/2024 as 5971/6067. The advisory is shared at github.com. This vulnerability is known as CVE-2024-3081. The attack can be launched remotely. Technical details are available. There is no exploit available. The price for an exploit might be around USD $0-$5k at the moment. MITRE ATT&CK project uses the attack technique T1059.007 for this issue. It is declared as not defined. We expect the 0-day to have been worth approximately $0-$5k. Upgrading to version 4.8.10 is able to address this issue. The updated version is ready for download at github.com. The identifier of the patch is 127436e4c3f56276d548070f99e61b7234200a11. The bugfix is ready for download at github.com. It is recommended to upgrade the affected component. A possible mitigation has been published even before and not after the disclosure of the vulnerability.

Timeline

The analysis of the timeline helps to identify the required approach and handling of single vulnerabilities and vulnerability collections. This overview makes it possible to see less important slices and more severe hotspots at a glance. Initiating immediate vulnerability response and prioritizing of issues is possible.

User

146

Field

vulnerability_cvss3_cna_basescore1
vulnerability_cvss2_nvd_basescore1
source_cve_cna1
vulnerability_cvss3_cna_a1
vulnerability_cvss3_cna_i1

Commit Conf

90%35
70%28
50%11
80%6
100%1

Approve Conf

90%35
80%28
70%17
100%1
IDCommitedUserFieldChangeRemarksAcceptedStatusC
1623396505/07/2024VulD...cvss3_cna_basescore3.5see CVSS documentation05/07/2024accepted
80
1623396405/07/2024VulD...cvss2_nvd_basescore4.0nist.gov05/07/2024accepted
80
1623396305/07/2024VulD...cve_cnaVulDBnvd.nist.gov05/07/2024accepted
70
1623396205/07/2024VulD...cvss3_cna_aNnvd.nist.gov05/07/2024accepted
70
1623396105/07/2024VulD...cvss3_cna_iLnvd.nist.gov05/07/2024accepted
70
1623396005/07/2024VulD...cvss3_cna_cNnvd.nist.gov05/07/2024accepted
70
1623395905/07/2024VulD...cvss3_cna_sUnvd.nist.gov05/07/2024accepted
70
1623395805/07/2024VulD...cvss3_cna_uiRnvd.nist.gov05/07/2024accepted
70
1623395705/07/2024VulD...cvss3_cna_prLnvd.nist.gov05/07/2024accepted
70
1623395605/07/2024VulD...cvss3_cna_acLnvd.nist.gov05/07/2024accepted
70
1623395505/07/2024VulD...cvss3_cna_avNnvd.nist.gov05/07/2024accepted
70
1623395405/07/2024VulD...cvss2_nvd_aiNnvd.nist.gov05/07/2024accepted
70
1623395305/07/2024VulD...cvss2_nvd_iiPnvd.nist.gov05/07/2024accepted
70
1623395205/07/2024VulD...cvss2_nvd_ciNnvd.nist.gov05/07/2024accepted
70
1623395105/07/2024VulD...cvss2_nvd_auSnvd.nist.gov05/07/2024accepted
70
1623395005/07/2024VulD...cvss2_nvd_acLnvd.nist.gov05/07/2024accepted
70
1623394905/07/2024VulD...cvss2_nvd_avNnvd.nist.gov05/07/2024accepted
70
1623394805/07/2024VulD...cve_nvd_summaryA vulnerability was found in EasyCorp EasyAdmin up to 4.8.9. It has been declared as problematic. Affected by this vulnerability is the function Autocomplete of the file assets/js/autocomplete.js of the component Autocomplete. The manipulation of the argument item leads to cross site scripting. The attack can be launched remotely. Upgrading to version 4.8.10 is able to address this issue. The identifier of the patch is 127436e4c3f56276d548070f99e61b7234200a11. It is recommended to upgrade the affected component. The identifier VDB-258613 was assigned to this vulnerability.cve.mitre.org05/07/2024accepted
70
1623394705/07/2024VulD...cve_assigned1711666800 (03/29/2024)cve.mitre.org05/07/2024accepted
70
1585105003/29/2024VulD...cveCVE-2024-3081cve.org03/29/2024accepted
100

61 more entries are not shown

Want to stay up to date on a daily basis?

Enable the mail alert feature now!