WP-DBManager up to 2.7.1 on WordPress Database Manager wp-dbmanager.php Credentials credentials management

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
5.5$0-$5k0.00

A vulnerability classified as problematic has been found in WP-DBManager up to 2.7.1 on WordPress (WordPress Plugin). This affects some unknown functionality of the file wp-dbmanager.php of the component Database Manager. The manipulation with an unknown input leads to a credentials management vulnerability (Credentials). CWE is classifying the issue as CWE-255. This is going to have an impact on confidentiality. The summary by CVE is:

(1) wp-dbmanager.php and (2) database-manage.php in the WP-DBManager (aka Database Manager) plugin before 2.7.2 for WordPress place credentials on the mysqldump command line, which allows local users to obtain sensitive information by listing the process.

The bug was discovered 10/16/2014. The weakness was presented 01/05/2018 (oss-sec). The advisory is shared at openwall.com. This vulnerability is uniquely identified as CVE-2014-8335 since 10/20/2014. An attack has to be approached locally. A authentication is required for exploitation. Technical details are known, but no exploit is available. MITRE ATT&CK project uses the attack technique T1552 for this issue.

The vulnerability was handled as a non-public zero-day exploit for at least 1177 days. During that time the estimated underground price was around $0-$5k. By approaching the search of inurl:wp-dbmanager.php it is possible to find vulnerable targets with Google Hacking. The commercial vulnerability scanner Qualys is able to test this issue with plugin 13068 (WordPress WP-DBManager plugin Remote Command Injection Vulnerability).

Upgrading to version 2.7.2 eliminates this vulnerability.

Productinfo

Type

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 5.5
VulDB Meta Temp Score: 5.5

VulDB Base Score: 3.3
VulDB Temp Score: 3.2
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 7.8
NVD Vector: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Name: Credentials
Class: Credentials management / Credentials
CWE: CWE-255
CAPEC: 🔍
ATT&CK: 🔍

Local: Yes
Remote: No

Availability: 🔍
Status: Not defined
Google Hack: 🔍

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: WP-DBManager 2.7.2
Patch: github.com

Timelineinfo

10/16/2014 🔍
10/20/2014 +4 days 🔍
01/05/2018 +1173 days 🔍
01/05/2018 +0 days 🔍
01/06/2018 +1 days 🔍
01/20/2023 +1840 days 🔍

Sourcesinfo

Advisory: 128785
Status: Not defined
Confirmation: 🔍

CVE: CVE-2014-8335 (🔍)
X-Force: 97691

Entryinfo

Created: 01/06/2018 05:09 PM
Updated: 01/20/2023 09:30 AM
Changes: 01/06/2018 05:09 PM (65), 12/19/2019 07:40 PM (1), 01/28/2021 05:21 PM (3), 01/20/2023 09:30 AM (4)
Complete: 🔍
Cache ID: 34:08D:40

Discussion

No comments yet. Languages: en.

Please log in to comment.

Interested in the pricing of exploits?

See the underground prices here!