Dijit <=1.11.10 up to 1.16.2 Editor's LinkDialog Plugin cross site scripting

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.

A vulnerability was found in Dijit <=1.11.10 up to 1.16.2. It has been classified as problematic. This affects an unknown functionality of the component Editor's LinkDialog Plugin. The manipulation with an unknown input leads to a cross site scripting vulnerability. CWE is classifying the issue as CWE-79. This is going to have an impact on integrity. An attacker might be able to inject arbitrary html and script code into the web site. This would alter the appearance and would make it possible to initiate further attacks against site visitors. The summary by CVE is:

In Dijit before versions 1.11.11, and greater than or equal to 1.12.0 and less than 1.12.9, and greater than or equal to 1.13.0 and less than 1.13.8, and greater than or equal to 1.14.0 and less than 1.14.7, and greater than or equal to 1.15.0 and less than 1.15.4, and greater than or equal to 1.16.0 and less than 1.16.3, there is a cross-site scripting vulnerability in the Editor's LinkDialog plugin. This has been fixed in 1.11.11, 1.12.9, 1.13.8, 1.14.7, 1.15.4, 1.16.3.

The weakness was shared 06/15/2020 (GitHub Repository). It is possible to read the advisory at github.com. This vulnerability is uniquely identified as CVE-2020-4051 since 12/30/2019. It is possible to initiate the attack remotely. The successful exploitation needs a authentication. It demands that the victim is doing some kind of user interaction. The technical details are unknown and an exploit is not publicly available. The attack technique deployed by this issue is T1059.007 according to MITRE ATT&CK.

Upgrading to version 1.11.11, 1.12.9, 1.13.8, 1.14.7, 1.15.4 or 1.16.3 eliminates this vulnerability.



CPE 2.3infoedit

CPE 2.2infoedit


VulDB Meta Base Score: 3.6
VulDB Meta Temp Score: 3.2

VulDB Base Score: 3.5
VulDB Temp Score: 3.1
VulDB Vector: 🔒
VulDB Reliability: 🔍

NVD Base Score: 3.7
NVD Vector: 🔒



VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍


Class: Cross site scripting
ATT&CK: T1059.007

Local: No
Remote: Yes

Availability: 🔒
Status: Not defined

Price Prediction: 🔍
Current Price Estimation: 🔒


Threat Intelligenceinfoedit

Threat: 🔍
Adversaries: 🔍
Geopolitics: 🔍
Economy: 🔍
Predictions: 🔍
Remediation: 🔍


Recommended: Upgrade
Status: 🔍

0-Day Time: 🔒

Upgrade: Dijit 1.11.11/1.12.9/1.13.8/1.14.7/1.15.4/1.16.3


12/30/2019 CVE assigned
06/15/2020 +168 days Advisory disclosed
06/16/2020 +1 days VulDB entry created
10/24/2020 +130 days VulDB last update


Advisory: github.com
Status: Not defined
Confirmation: 🔒

CVE: CVE-2020-4051 (🔒)


Created: 06/16/2020 11:57 AM
Updated: 10/24/2020 05:24 PM
Changes: (1) source_cve_cna
Complete: 🔍


No comments yet. Please log in to comment.

Do you need the next level of professionalism?

Upgrade your account now!