SAP NetWeaver AS JAVA 7.3/7.4/7.5 LM Configuration Wizard RECON improper authentication

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
9.8$0-$5k0.00

A vulnerability was found in SAP NetWeaver AS JAVA 7.3/7.4/7.5 (Solution Stack Software) and classified as very critical. Affected by this issue is an unknown part of the component LM Configuration Wizard. The manipulation with an unknown input leads to a improper authentication vulnerability (RECON). Using CWE to declare the problem leads to CWE-287. When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct. Impacted is confidentiality, integrity, and availability. CVE summarizes:

SAP NetWeaver AS JAVA (LM Configuration Wizard), versions - 7.30, 7.31, 7.40, 7.50, does not perform an authentication check which allows an attacker without prior authentication to execute configuration tasks to perform critical actions against the SAP Java system, including the ability to create an administrative user, and therefore compromising Confidentiality, Integrity and Availability of the system, leading to Missing Authentication Check.

The weakness was shared 07/14/2020 with Onapsis as 552599675 / 2934135 (Website). The advisory is available at onapsis.com. The vendor cooperated in the coordination of the public release. This vulnerability is handled as CVE-2020-6287. The attack may be launched remotely. No form of authentication is required for exploitation. Technical details are unknown but a public exploit is available. The structure of the vulnerability defines a possible price range of USD $0-$5k at the moment (estimation calculated on 04/20/2024).

A public exploit has been developed by Spencer McIntyre (zeroSteiner) in Ruby/Metasploit and been published 2 weeks after the advisory. The exploit is available at github.com. It is declared as highly functional. As 0-day the estimated underground price was around $100k and more. This issue was added on 11/03/2021 to the CISA Known Exploited Vulnerabilities Catalog with a due date of 05/03/2022:

Apply updates per vendor instructions.

Applying a patch is able to eliminate this problem. A possible mitigation has been published before and not just after the disclosure of the vulnerability.

zdnet.com is providing further details. The entry VDB-158058 is related to this item.

Affected

  • SAP Enterprise Resource Planning
  • SAP Product Lifecycle Management
  • SAP Customer Relationship Management
  • SAP Supply Chain Management
  • SAP Supplier Relationship Management
  • SAP NetWeaver Business Warehouse
  • SAP Business Intelligence
  • SAP NetWeaver Mobile Infrastructure
  • SAP Enterprise Portal
  • SAP Process Orchestration/Process Integration
  • SAP Solution Manager
  • SAP NetWeaver Development Infrastructure
  • SAP Central Process Scheduling
  • SAP NetWeaver Composition Environment
  • SAP Landscape Manager

Productinfo

Type

Vendor

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 10.0
VulDB Meta Temp Score: 9.8

VulDB Base Score: 10.0
VulDB Temp Score: 9.5
VulDB Vector: 🔍
VulDB Reliability: 🔍

Vendor Base Score (SAP): 10.0
Vendor Vector (SAP): 🔍

NVD Base Score: 10.0
NVD Vector: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Name: RECON
Class: Improper authentication / RECON
CWE: CWE-287
CAPEC: 🔍
ATT&CK: 🔍

Local: No
Remote: Yes

Availability: 🔍
Access: Public
Status: Highly functional
Author: Spencer McIntyre (zeroSteiner)
Programming Language: 🔍
Download: 🔍

EPSS Score: 🔍
EPSS Percentile: 🔍

KEV Added: 🔍
KEV Due: 🔍
KEV Remediation: 🔍
KEV Ransomware: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Patch
Status: 🔍

0-Day Time: 🔍
Exploit Delay Time: 🔍

Timelineinfo

01/08/2020 🔍
07/13/2020 +187 days 🔍
07/14/2020 +1 days 🔍
07/14/2020 +0 days 🔍
07/23/2020 +9 days 🔍
04/20/2024 +1367 days 🔍

Sourcesinfo

Vendor: sap.com

Advisory: 552599675 / 2934135
Organization: Onapsis
Status: Confirmed
Coordinated: 🔍

CVE: CVE-2020-6287 (🔍)
scip Labs: https://www.scip.ch/en/?labs.20150716
Misc.: 🔍
See also: 🔍

Entryinfo

Created: 07/14/2020 08:38 AM
Updated: 04/20/2024 08:21 AM
Changes: 07/14/2020 08:38 AM (56), 07/25/2020 08:40 AM (21), 07/25/2020 08:41 AM (5), 10/29/2020 01:45 PM (1), 10/29/2020 01:52 PM (1), 04/20/2024 08:21 AM (28)
Complete: 🔍
Committer: misc
Cache ID: 34:A90:40

Discussion

No comments yet. Languages: en.

Please log in to comment.

Interested in the pricing of exploits?

See the underground prices here!