Cisco AnyConnect Secure Mobility Client on Linux/macOS Interprocess Communication toctou

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
6.8$0-$5k0.00

A vulnerability was found in Cisco AnyConnect Secure Mobility Client on Linux/macOS (Network Encryption Software) (the affected version unknown). It has been classified as critical. This affects an unknown function of the component Interprocess Communication Handler. The manipulation with an unknown input leads to a race condition vulnerability. CWE is classifying the issue as CWE-367. This is going to have an impact on confidentiality, integrity, and availability. The summary by CVE is:

A vulnerability in the shared library loading mechanism of Cisco AnyConnect Secure Mobility Client for Linux and Mac OS could allow an authenticated, local attacker to perform a shared library hijacking attack on an affected device if the VPN Posture (HostScan) Module is installed on the AnyConnect client. This vulnerability is due to a race condition in the signature verification process for shared library files that are loaded on an affected device. An attacker could exploit this vulnerability by sending a series of crafted interprocess communication (IPC) messages to the AnyConnect process. A successful exploit could allow the attacker to execute arbitrary code on the affected device with root privileges. To exploit this vulnerability, the attacker must have a valid account on the system.

The weakness was shared 10/07/2021 as cisco-sa-anyconnect-lib-hija-cAFB7x4q. It is possible to read the advisory at tools.cisco.com. This vulnerability is uniquely identified as CVE-2021-34788 since 06/15/2021. The exploitability is told to be difficult. Attacking locally is a requirement. The successful exploitation requires a authentication. The technical details are unknown and an exploit is not publicly available.

Upgrading eliminates this vulnerability.

Productinfoedit

Type

Vendor

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 7.0
VulDB Meta Temp Score: 6.8

VulDB Base Score: 7.0
VulDB Temp Score: 6.7
VulDB Vector: 🔒
VulDB Reliability: 🔍

CNA Base Score: 7.0
CNA Vector (Cisco Systems, Inc.): 🔒

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍

Exploitinginfoedit

Class: Race condition
CWE: CWE-367
ATT&CK: Unknown

Local: Yes
Remote: No

Availability: 🔒
Status: Not defined
Price Prediction: 🔍
Current Price Estimation: 🔒

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Threat Intelligenceinfoedit

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfoedit

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔒

Upgrade: tools.cisco.com

Timelineinfoedit

06/15/2021 CVE assigned
10/07/2021 +114 days Advisory disclosed
10/07/2021 +0 days VulDB entry created
10/09/2021 +2 days VulDB last update

Sourcesinfoedit

Vendor: https://www.cisco.com/

Advisory: cisco-sa-anyconnect-lib-hija-cAFB7x4q
Status: Confirmed

CVE: CVE-2021-34788 (🔒)

Entryinfoedit

Created: 10/07/2021 07:53 AM
Updated: 10/09/2021 06:17 PM
Changes: (1) source_cve_nvd_summary
Complete: 🔍

Comments

No comments yet. Languages: en.

Please log in to comment.

Want to stay up to date on a daily basis?

Enable the mail alert feature now!