miniOrange Google Authenticator Plugin up to 5.5.5 on WordPress cross site scripting

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.

A vulnerability was found in miniOrange Google Authenticator Plugin up to 5.5.5 on WordPress (WordPress Plugin) and classified as problematic. Affected by this issue is an unknown code. The manipulation with an unknown input leads to a cross site scripting vulnerability. Using CWE to declare the problem leads to CWE-79. The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users. Impacted is integrity. CVE summarizes:

The miniOrange's Google Authenticator WordPress plugin before 5.5.6 does not sanitise and escape some of its settings, leading to malicious users with administrator privileges to store malicious Javascript code leading to Cross-Site Scripting attacks when unfiltered_html is disallowed (for example in multisite setup)

The weakness was released 06/27/2022. The advisory is available at This vulnerability is handled as CVE-2022-1321 since 04/12/2022. Successful exploitation requires user interaction by the victim. The technical details are unknown and an exploit is not available. This vulnerability is assigned to T1059.007 by the MITRE ATT&CK project.

Upgrading to version 5.5.6 eliminates this vulnerability.







CPE 2.3info

CPE 2.2info


VulDB Meta Base Score: 4.1
VulDB Meta Temp Score: 4.1

VulDB Base Score: 3.5
VulDB Temp Score: 3.4
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 4.8
NVD Vector: 🔍



VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍


Class: Cross site scripting
CWE: CWE-79 / CWE-74 / CWE-707
ATT&CK: T1059.007

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍


Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍


Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: Google Authenticator Plugin 5.5.6


04/12/2022 🔍
06/27/2022 +76 days 🔍
06/27/2022 +0 days 🔍
07/15/2022 +18 days 🔍


Status: Confirmed

CVE: CVE-2022-1321 (🔍)


Created: 06/27/2022 12:31 PM
Updated: 07/15/2022 11:18 AM
Changes: 06/27/2022 12:31 PM (41), 07/15/2022 11:18 AM (18)
Complete: 🔍


No comments yet. Languages: en.

Please log in to comment.

Do you need the next level of professionalism?

Upgrade your account now!