KDE Paste Applet up to 4.10.4 kdeplasma-addons pastemacroexpander.cpp improper authentication

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
6.6$0-$5k0.00

A vulnerability, which was classified as critical, was found in KDE Paste Applet up to 4.10.4. Affected is an unknown functionality of the file pastemacroexpander.cpp of the component kdeplasma-addons. The manipulation with an unknown input leads to a improper authentication vulnerability. CWE is classifying the issue as CWE-287. When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct. This is going to have an impact on confidentiality, integrity, and availability. CVE summarizes:

The %{password(...)} macro in pastemacroexpander.cpp in the KDE Paste Applet before 4.10.5 in kdeplasma-addons does not properly generate passwords, which allows context-dependent attackers to bypass authentication via a brute-force attack.

The weakness was released 04/21/2023. The advisory is available at archives.neohapsis.com. This vulnerability is traded as CVE-2013-2120 since 02/19/2013. The exploitability is told to be easy. Local access is required to approach this attack. The successful exploitation needs a authentication. Technical details and a public exploit are known.

The exploit is shared for download at openwall.com. It is declared as proof-of-concept. The vulnerability scanner Nessus provides a plugin with the ID 67272 (Fedora 17 : analitza-4.10.4-1.fc17 / ark-4.10.4-1.fc17 / audiocd-kio-4.10.4-1.fc17 / etc (2013-10182)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Fedora Local Security Checks.

Upgrading to version 4.10.5 eliminates this vulnerability.

The vulnerability is also documented in the vulnerability database at Tenable (67272). Entry connected to this vulnerability is available at VDB-227045.

Productinfo

Vendor

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 6.8
VulDB Meta Temp Score: 6.6

VulDB Base Score: 5.3
VulDB Temp Score: 4.8
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 8.4
NVD Vector: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Improper authentication
CWE: CWE-287
CAPEC: 🔍
ATT&CK: 🔍

Local: Yes
Remote: No

Availability: 🔍
Access: Public
Status: Proof-of-Concept
Download: 🔍

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 67272
Nessus Name: Fedora 17 : analitza-4.10.4-1.fc17 / ark-4.10.4-1.fc17 / audiocd-kio-4.10.4-1.fc17 / etc (2013-10182)
Nessus Family: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: Paste Applet 4.10.5

Timelineinfo

02/19/2013 🔍
07/12/2013 +142 days 🔍
04/21/2023 +3570 days 🔍
04/21/2023 +0 days 🔍
06/11/2024 +417 days 🔍

Sourcesinfo

Vendor: kde.org

Advisory: archives.neohapsis.com
Status: Confirmed

CVE: CVE-2013-2120 (🔍)
scip Labs: https://www.scip.ch/en/?labs.20161013
See also: 🔍

Entryinfo

Created: 04/21/2023 10:29 PM
Updated: 06/11/2024 04:29 PM
Changes: 04/21/2023 10:29 PM (60), 06/11/2024 04:29 PM (18)
Complete: 🔍
Cache ID: 34:C5A:40

Discussion

No comments yet. Languages: en.

Please log in to comment.

Interested in the pricing of exploits?

See the underground prices here!