SourceFire ClamAV up to 0.95.0 libclamav/phishcheck.c cli_url_canon memory corruption

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
9.0$0-$5k0.00

A vulnerability classified as very critical was found in SourceFire ClamAV up to 0.95.0 (Anti-Malware Software). This vulnerability affects the function cli_url_canon of the file libclamav/phishcheck.c. The manipulation with an unknown input leads to a memory corruption vulnerability. The CWE definition for the vulnerability is CWE-119. The product performs operations on a memory buffer, but it can read from or write to a memory location that is outside of the intended boundary of the buffer. As an impact it is known to affect confidentiality, integrity, and availability. CVE summarizes:

Stack-based buffer overflow in the cli_url_canon function in libclamav/phishcheck.c in ClamAV before 0.95.1 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a crafted URL.

The weakness was disclosed 04/09/2009 by Martin (Website). The advisory is shared for download at vupen.com. This vulnerability was named CVE-2009-1372 since 04/23/2009. The exploitation appears to be easy. The attack can be initiated remotely. No form of authentication is required for a successful exploitation. There are known technical details, but no exploit is available. The current price for an exploit might be approx. USD $0-$5k (estimation calculated on 08/09/2021).

It is declared as proof-of-concept. The vulnerability scanner Nessus provides a plugin with the ID 36131 (ClamAV < 0.95.1 Multiple Vulnerabilities), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Misc.. The commercial vulnerability scanner Qualys is able to test this issue with plugin 116609 (Apple Mac OS X Security Update 2009-005 Not Installed (APPLE-SA-2009-09-10-2)).

Upgrading to version 0.95.1 eliminates this vulnerability. A possible mitigation has been published before and not just after the disclosure of the vulnerability.

The vulnerability is also documented in the databases at X-Force (49790) and Tenable (36131). The entries 47871, 47520, 50018 and 50017 are pretty similar.

Productinfo

Type

Vendor

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv3info

VulDB Meta Base Score: 10.0
VulDB Meta Temp Score: 9.0

VulDB Base Score: 10.0
VulDB Temp Score: 9.0
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Memory corruption
CWE: CWE-119
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Status: Proof-of-Concept

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 36131
Nessus Name: ClamAV < 0.95.1 Multiple Vulnerabilities
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍

OpenVAS ID: 64873
OpenVAS Name: Gentoo Security Advisory GLSA 200909-04 (clamav)
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: ClamAV 0.95.1

Timelineinfo

04/08/2009 🔍
04/09/2009 +1 days 🔍
04/09/2009 +0 days 🔍
04/09/2009 +0 days 🔍
04/09/2009 +0 days 🔍
04/09/2009 +0 days 🔍
04/10/2009 +0 days 🔍
04/13/2009 +3 days 🔍
04/23/2009 +10 days 🔍
04/23/2009 +0 days 🔍
03/17/2015 +2154 days 🔍
08/09/2021 +2337 days 🔍

Sourcesinfo

Vendor: cisco.com

Advisory: vupen.com
Researcher: Martin
Status: Confirmed
Confirmation: 🔍

CVE: CVE-2009-1372 (🔍)
X-Force: 49790
SecurityTracker: 1022028 - Clam AntiVirus UPack File and URL Processing Bugs Let Remote Users Deny Service
Vulnerability Center: 21565 - ClamAV 0.90.1 - 0.94.2 Remote DoS Vulnerability via a Crafted URLs, Medium
SecurityFocus: 34446 - ClamAV Prior to 0.95.1 Multiple Remote Denial of Service Vulnerabilities
Secunia: 34612 - ClamAV UPack Denial of Service and "cli_url_canon()" Buffer Overflow, Highly Critical
OSVDB: 53603 - ClamAV libclamav/phishcheck.c cli_url_canon() Function URL Handling Overflow
Vupen: ADV-2009-0985

See also: 🔍

Entryinfo

Created: 03/17/2015 11:38 PM
Updated: 08/09/2021 05:18 PM
Changes: 03/17/2015 11:38 PM (71), 05/10/2019 06:29 PM (17), 08/09/2021 05:18 PM (2)
Complete: 🔍

Discussion

No comments yet. Languages: en.

Please log in to comment.

Do you need the next level of professionalism?

Upgrade your account now!