Adobe Shockwave Player prior 6.0 memory corruption

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
9.0$0-$5k0.00

A vulnerability was found in Adobe Shockwave Player (Multimedia Player Software). It has been classified as critical. This affects an unknown functionality. The manipulation with an unknown input leads to a memory corruption vulnerability. CWE is classifying the issue as CWE-119. The product performs operations on a memory buffer, but it can read from or write to a memory location that is outside of the intended boundary of the buffer. This is going to have an impact on confidentiality, integrity, and availability. The summary by CVE is:

Adobe Shockwave Player before 11.5.7.609 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted .dir (aka Director) file, related to (1) an erroneous dereference and (2) a certain Shock.dir file.

The weakness was disclosed 05/13/2010 by LiquidWorm (Website). It is possible to read the advisory at vupen.com. This vulnerability is uniquely identified as CVE-2010-1280. It is possible to initiate the attack remotely. No form of authentication is needed for exploitation. Technical details are unknown but a public exploit is available.

A public exploit has been developed by LiquidWorm in ANSI C and been published before and not just after the advisory. The exploit is shared for download at securityfocus.com. It is declared as proof-of-concept. The vulnerability was handled as a non-public zero-day exploit for at least 1 days. During that time the estimated underground price was around $5k-$25k. The vulnerability scanner Nessus provides a plugin with the ID 46329 (Shockwave Player < 11.5.7.609 Multiple Vulnerabilities (APSB10-12)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Windows. The commercial vulnerability scanner Qualys is able to test this issue with plugin 118031 (Adobe Shockwave Player Remote Code Execution Vulnerability (APSB10-12)).

Upgrading to version 6.0 eliminates this vulnerability.

The vulnerability is also documented in the databases at Tenable (46329) and Exploit-DB (12578).

Productinfo

Type

Vendor

Name

License

Support

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 10.0
VulDB Meta Temp Score: 9.0

VulDB Base Score: 10.0
VulDB Temp Score: 9.0
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Memory corruption
CWE: CWE-119
CAPEC: 🔍
ATT&CK: 🔍

Local: No
Remote: Yes

Availability: 🔍
Access: Public
Status: Proof-of-Concept
Author: LiquidWorm
Programming Language: 🔍
Download: 🔍

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 46329
Nessus Name: Shockwave Player < 11.5.7.609 Multiple Vulnerabilities (APSB10-12)
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍

OpenVAS ID: 801335
OpenVAS Name: Adobe Shockwave Player Multiple Remote Code Execution Vulnerabilities May-10
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Exploit-DB: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: Shockwave Player 6.0
McAfee IPS: 🔍
McAfee IPS Version: 🔍

ISS Proventia IPS: 🔍

Timelineinfo

04/06/2010 🔍
05/11/2010 +35 days 🔍
05/11/2010 +0 days 🔍
05/12/2010 +1 days 🔍
05/12/2010 +0 days 🔍
05/13/2010 +1 days 🔍
05/13/2010 +0 days 🔍
05/16/2010 +3 days 🔍
03/19/2015 +1768 days 🔍
09/13/2021 +2370 days 🔍

Sourcesinfo

Vendor: adobe.com

Advisory: vupen.com
Researcher: LiquidWorm
Status: Confirmed
Confirmation: 🔍

CVE: CVE-2010-1280 (🔍)
OVAL: 🔍

Vulnerability Center: 25727 - [APSB10-12] Adobe Shockwave Player Remote Arbitrary Code Execution or DoS Vulnerability via a Crafted .dir File, Critical
SecurityFocus: 40081 - Adobe Shockwave Player DIR File Parsing Remote Code Execution Vulnerabilities
Secunia: 38751

scip Labs: https://www.scip.ch/en/?labs.20161013

Entryinfo

Created: 03/19/2015 12:22 PM
Updated: 09/13/2021 11:13 AM
Changes: 03/19/2015 12:22 PM (65), 02/24/2017 10:15 AM (16), 09/13/2021 11:06 AM (4), 09/13/2021 11:13 AM (1)
Complete: 🔍
Cache ID: 44:BCD:40

Discussion

No comments yet. Languages: en.

Please log in to comment.

Interested in the pricing of exploits?

See the underground prices here!