IBM WebSphere Application Server up to 8.0.0.6 information disclosure

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
5.1$0-$5k0.00

A vulnerability has been found in IBM WebSphere Application Server up to 8.0.0.6 (Application Server Software) and classified as critical. Affected by this vulnerability is an unknown functionality. The manipulation with an unknown input leads to a information disclosure vulnerability. The CWE definition for the vulnerability is CWE-200. The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information. As an impact it is known to affect confidentiality. The summary by CVE is:

IBM WebSphere Application Server 8.0.x before 8.0.0.10 and 8.5.x before 8.5.5.4 allows remote attackers to spoof OpenID and OpenID Connect cookies, and consequently obtain sensitive information, via a crafted URL.

The weakness was released 12/18/2014 (Website). It is possible to read the advisory at xforce.iss.net. This vulnerability is known as CVE-2014-6164 since 09/02/2014. The exploitation appears to be easy. The attack can be launched remotely. The exploitation doesn't need any form of authentication. The technical details are unknown and an exploit is not publicly available. The attack technique deployed by this issue is T1592 according to MITRE ATT&CK.

The vulnerability scanner Nessus provides a plugin with the ID 80398 (IBM WebSphere Application Server 8.5 < Fix Pack 8.5.5.4 Multiple Vulnerabilities (POODLE)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Web Servers. The commercial vulnerability scanner Qualys is able to test this issue with plugin 87273 (IBM WebSphere Application Server 8.0 Fix Pack 10 Missing).

Upgrading to version 8.0.0.7 eliminates this vulnerability.

The vulnerability is also documented in the databases at X-Force (97713) and Tenable (80398). Entries connected to this vulnerability are available at 72125, 73295, 73294 and 73293.

Productinfo

Type

Vendor

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv3info

VulDB Meta Base Score: 5.3
VulDB Meta Temp Score: 5.1

VulDB Base Score: 5.3
VulDB Temp Score: 5.1
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Information disclosure
CWE: CWE-200 / CWE-284 / CWE-266
ATT&CK: T1592

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 80398
Nessus Name: IBM WebSphere Application Server 8.5 < Fix Pack 8.5.5.4 Multiple Vulnerabilities (POODLE)
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍

OpenVAS ID: 103277
OpenVAS Name: IBM Websphere Apllication Server Information Disclosure Vulnerability-05 Mar16
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: WebSphere Application Server 8.0.0.7

Timelineinfo

09/02/2014 🔍
12/18/2014 +107 days 🔍
12/18/2014 +0 days 🔍
12/18/2014 +0 days 🔍
12/22/2014 +4 days 🔍
03/22/2015 +90 days 🔍
03/27/2015 +5 days 🔍
04/09/2022 +2570 days 🔍

Sourcesinfo

Vendor: ibm.com

Advisory: xforce.iss.net
Status: Not defined
Confirmation: 🔍

CVE: CVE-2014-6164 (🔍)
X-Force: 97713
Vulnerability Center: 49169 - IBM WebSphere Application Server 8.x Remote OpenID and OpenID Connect Cookies Spoofing Vulnerability, Medium
SecurityFocus: 71837 - IBM WebSphere Application Server CVE-2014-6164 Information Disclosure Vulnerability

See also: 🔍

Entryinfo

Created: 03/27/2015 02:56 PM
Updated: 04/09/2022 11:14 AM
Changes: 03/27/2015 02:56 PM (63), 06/23/2017 10:31 AM (8), 04/09/2022 11:14 AM (3)
Complete: 🔍

Discussion

No comments yet. Languages: en.

Please log in to comment.

Do you know our Splunk app?

Download it now for free!