Justin Klein WP-ViperGB up to 1.3.9 vgb_items_per_pg cross-site request forgery

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.

A vulnerability, which was classified as critical, was found in Justin Klein WP-ViperGB up to 1.3.9 (WordPress Plugin). Affected is some unknown functionality. The manipulation of the argument vgb_items_per_pg with an unknown input leads to a cross-site request forgery vulnerability. CWE is classifying the issue as CWE-352. The web application does not, or can not, sufficiently verify whether a well-formed, valid, consistent request was intentionally provided by the user who submitted the request. This is going to have an impact on confidentiality, integrity, and availability. CVE summarizes:

Multiple cross-site request forgery (CSRF) vulnerabilities in the WP-ViperGB plugin before 1.3.11 for WordPress allow remote attackers to hijack the authentication of administrators for requests that (1) change plugin settings via unspecified vectors or conduct cross-site scripting (XSS) attacks via the (2) vgb_page or (3) vgb_items_per_pg parameter in the wp-vipergb page to wp-admin/options-general.php.

The weakness was presented 01/02/2015 (Website). The advisory is shared for download at wordpress.org. This vulnerability is traded as CVE-2014-9460 since 01/02/2015. It is possible to launch the attack remotely. The exploitation doesn't require any form of authentication. Successful exploitation requires user interaction by the victim. There are known technical details, but no exploit is available.

Upgrading to version 1.3.10 eliminates this vulnerability.

The vulnerability is also documented in the vulnerability database at X-Force (99440).






CPE 2.3info

CPE 2.2info


VulDB Meta Base Score: 6.3
VulDB Meta Temp Score: 6.0

VulDB Base Score: 6.3
VulDB Temp Score: 6.0
VulDB Vector: 🔍
VulDB Reliability: 🔍



VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍


Class: Cross-site request forgery
CWE: CWE-352 / CWE-862 / CWE-863
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍


Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍


Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: WP-ViperGB 1.3.10


01/02/2015 🔍
01/02/2015 +0 days 🔍
01/02/2015 +0 days 🔍
03/27/2015 +84 days 🔍
04/10/2022 +2571 days 🔍


Advisory: 129501
Status: Not defined
Confirmation: 🔍

CVE: CVE-2014-9460 (🔍)
X-Force: 99440


Created: 03/27/2015 02:56 PM
Updated: 04/10/2022 01:51 PM
Changes: 03/27/2015 02:56 PM (45), 04/08/2018 11:55 AM (6), 04/10/2022 01:51 PM (3)
Complete: 🔍


No comments yet. Languages: en.

Please log in to comment.

Might our Artificial Intelligence support you?

Check our Alexa App!