PHP 5.4.41/5.5.25/5.6.9 ftp_genlist memory corruption

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
8.1$0-$5k0.00

A vulnerability, which was classified as critical, has been found in PHP 5.4.41/5.5.25/5.6.9 (Programming Language Software). Affected by this issue is the function ftp_genlist. The manipulation with an unknown input leads to a memory corruption vulnerability. Using CWE to declare the problem leads to CWE-119. The product performs operations on a memory buffer, but it can read from or write to a memory location that is outside of the intended boundary of the buffer. Impacted is confidentiality, integrity, and availability.

The weakness was released 06/18/2015 by Tomas Hoger as confirmed mailinglist post (oss-sec). The advisory is shared for download at seclists.org. This vulnerability is handled as CVE-2015-4643 since 06/18/2015. The exploitation is known to be easy. The attack may be launched remotely. No form of authentication is required for exploitation. There are known technical details, but no exploit is available.

The vulnerability scanner Nessus provides a plugin with the ID 84326 (FreeBSD : php5 -- multiple vulnerabilities (cdff0af2-1492-11e5-a1cf-002590263bf5)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family FreeBSD Local Security Checks. The commercial vulnerability scanner Qualys is able to test this issue with plugin 350141 (Amazon Linux Security Advisory for php54: ALAS-2015-561).

Upgrading to version 5.4.42, 5.6.10 or 5.5.26 eliminates this vulnerability.

The vulnerability is also documented in the databases at X-Force (103926) and Tenable (84326).

Productinfo

Type

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 8.5
VulDB Meta Temp Score: 8.1

VulDB Base Score: 7.3
VulDB Temp Score: 6.4
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 9.8
NVD Vector: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Memory corruption
CWE: CWE-119
CAPEC: 🔍
ATT&CK: 🔍

Local: No
Remote: Yes

Availability: 🔍
Status: Unproven

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 84326
Nessus Name: FreeBSD : php5 -- multiple vulnerabilities (cdff0af2-1492-11e5-a1cf-002590263bf5)
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Port: 🔍

OpenVAS ID: 703344
OpenVAS Name: Debian Security Advisory DSA 3344-1 (php5 - security update)
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: PHP 5.4.42/5.6.10/5.5.26
Patch: 0765623d6991b62ffcd93ddb6be8a5203a2fa7e2

Timelineinfo

06/18/2015 🔍
06/18/2015 +0 days 🔍
06/18/2015 +0 days 🔍
06/18/2015 +0 days 🔍
06/19/2015 +1 days 🔍
06/21/2015 +2 days 🔍
06/23/2015 +2 days 🔍
06/25/2015 +2 days 🔍
05/16/2016 +326 days 🔍
05/21/2022 +2196 days 🔍

Sourcesinfo

Product: php.org

Advisory: 69545
Researcher: Tomas Hoger
Status: Confirmed
Confirmation: 🔍

CVE: CVE-2015-4643 (🔍)
OVAL: 🔍

X-Force: 103926 - PHP ftp_genlist() buffer overflow
SecurityTracker: 1032709 - PHP Multiple Bugs Let Remote Users Deny Service and Execute Arbitrary Code
Vulnerability Center: 50646 - PHP 5.4 - 5.4.40, 5.5 - 5.5.24, 5.6 - 5.6.8 Remote Code Execution due to Integer Overflow in ftp_genlist() - CVE-2015-4643, High
SecurityFocus: 75291 - PHP 'ftp_genlist()' Function Incomplete Fix Integer Overflow Vulnerability

Entryinfo

Created: 06/19/2015 10:45 AM
Updated: 05/21/2022 01:00 PM
Changes: 06/19/2015 10:45 AM (86), 07/01/2017 08:00 AM (5), 05/21/2022 12:45 PM (7), 05/21/2022 12:53 PM (1), 05/21/2022 01:00 PM (1)
Complete: 🔍
Cache ID: 44:C8F:40

Discussion

No comments yet. Languages: en.

Please log in to comment.

Interested in the pricing of exploits?

See the underground prices here!