Adobe Acrobat Reader up to 10.1.15/11.0.12 use after free

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
6.0$0-$5k0.00

A vulnerability was found in Adobe Acrobat Reader up to 10.1.15/11.0.12 (Document Reader Software). It has been rated as critical. Affected by this issue is an unknown code block. The manipulation with an unknown input leads to a use after free vulnerability. Using CWE to declare the problem leads to CWE-416. Referencing memory after it has been freed can cause a program to crash, use unexpected values, or execute code. Impacted is confidentiality, integrity, and availability.

The weakness was presented 10/13/2015 by AbdulAziz Hariri (iDefense) with Nanyang Technological University as APSB15-24 as confirmed knowledge base article (Website). The advisory is available at helpx.adobe.com. This vulnerability is handled as CVE-2015-6687 since 08/26/2015. The attack may be launched remotely. No form of authentication is required for exploitation. Successful exploitation requires user interaction by the victim. The technical details are unknown and an exploit is not available.

The vulnerability scanner Nessus provides a plugin with the ID 86402 (Adobe Acrobat <= 10.1.15 / 11.0.12 / 2015.006.30060 / 2015.008.20082 Multiple Vulnerabilities (APSB15-24)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Windows. The commercial vulnerability scanner Qualys is able to test this issue with plugin 124151 (Adobe Reader and Acrobat Multiple Vulnerabilities (APSB15-24)).

Upgrading to version 10.1.16 or 11.0.13 eliminates this vulnerability. A possible mitigation has been published immediately after the disclosure of the vulnerability.

The vulnerability is also documented in the vulnerability database at Tenable (86402). isc.sans.edu is providing further details. See 78392, 78393, 78394 and 78395 for similar entries.

Productinfo

Type

Vendor

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 6.3
VulDB Meta Temp Score: 6.0

VulDB Base Score: 6.3
VulDB Temp Score: 6.0
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Use after free
CWE: CWE-416 / CWE-119
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 86402
Nessus Name: Adobe Acrobat <= 10.1.15 / 11.0.12 / 2015.006.30060 / 2015.008.20082 Multiple Vulnerabilities (APSB15-24)
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍

OpenVAS ID: 103192
OpenVAS Name: Adobe Reader Multiple Vulnerabilities - 01 October15 (Windows)
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

Reaction Time: 🔍
0-Day Time: 🔍
Exposure Time: 🔍

Upgrade: Acrobat Reader 10.1.16/11.0.13

Timelineinfo

08/26/2015 🔍
10/13/2015 +48 days 🔍
10/13/2015 +0 days 🔍
10/13/2015 +0 days 🔍
10/13/2015 +0 days 🔍
10/13/2015 +0 days 🔍
10/14/2015 +1 days 🔍
10/14/2015 +0 days 🔍
10/14/2015 +0 days 🔍
06/21/2022 +2442 days 🔍

Sourcesinfo

Vendor: adobe.com

Advisory: APSB15-24
Researcher: AbdulAziz Hariri (iDefense)
Organization: Nanyang Technological University
Status: Confirmed
Confirmation: 🔍

CVE: CVE-2015-6687 (🔍)
SecurityTracker: 1033796 - Adobe Acrobat/Reader Multiple Flaws Let Remote Users Obtain Potentially Sensitive Information, Execute Arbitrary Code, and Bypass Security Restrictions
Vulnerability Center: 53416 - [APSB15-24] Adobe Acrobat and Reader Remote Code Execution due to Use-After-Free - CVE-2015-6687, Critical
SecurityFocus: 77064 - Adobe Acrobat and Reader APSB15-24 Use-After-Free Multiple Remote Code Execution Vulnerabilities

Misc.: 🔍
See also: 🔍

Entryinfo

Created: 10/14/2015 04:21 PM
Updated: 06/21/2022 08:51 AM
Changes: 10/14/2015 04:21 PM (63), 04/07/2017 10:47 AM (18), 06/21/2022 08:47 AM (2), 06/21/2022 08:51 AM (1)
Complete: 🔍

Discussion

No comments yet. Languages: en.

Please log in to comment.

Want to stay up to date on a daily basis?

Enable the mail alert feature now!