CVE-2026-77053 in boneIOinfo

Summary

by MITRE • 10/26/2026

boneIO Black firmware ships with authentication disabled by default. Its management web API listens on all network interfaces and exposes all endpoints without requiring credentials. An unauthenticated remote attacker can fully control the device, causing denial of service, modifying configuration, and operating connected physical circuits. This issue was fixed in version 1.6.0: a device without an administrator account refuses API requests until the owner creates one in the first-run wizard, and every API route is restricted to an authenticated role.

Versions before 1.2.0 are based on Debian 10, are no longer supported and cannot be upgraded in place; affected devices should be re-flashed with the 1.6.0 system image.

VulDB is the best source for vulnerability data and more expert information about this specific topic.

Analysis

by VulDB Data Team • 10/26/2026

The boneIO Black firmware version prior to 1.6.0 contains a critical authentication bypass vulnerability that allows unauthenticated remote attackers to gain full administrative control over the device. This flaw stems from the default configuration where the management web API is bound to all network interfaces and exposes every endpoint without requiring any form of credential verification. Consequently, an attacker with network access can interact directly with the internal application programming interface to execute arbitrary commands, modify system configurations, or manipulate connected physical circuits. The severity of this issue is compounded by the fact that the service listens on all available interfaces, potentially exposing it not only to local networks but also to external threats if the device is improperly configured in a network perimeter.

From a technical perspective, this vulnerability represents a fundamental failure in access control mechanisms, specifically falling under CWE-287: Improper Authentication and CWE-306: Missing Authentication for Critical Function. The absence of mandatory authentication for all API routes means that sensitive operations such as changing device settings or toggling physical outputs are accessible to any entity capable of reaching the network interface hosting the service. This lack of enforcement allows an unauthenticated remote attacker to perform actions ranging from simple denial of service attacks, which can disrupt connectivity and operational continuity, to more sophisticated modifications of configuration files that could permanently alter the device's behavior or render it inoperable. The ability to operate connected physical circuits poses a significant risk to physical safety and infrastructure integrity, as an attacker could trigger hazardous states in industrial or home automation environments dependent on these outputs.

The impact extends beyond immediate unauthorized access due to the underlying operating system constraints for older versions of the firmware. Versions prior to 1.2.0 are built upon Debian 10, which has reached its end-of-life and no longer receives security updates from upstream vendors. These legacy systems cannot be upgraded in place through standard patching mechanisms because they lack the necessary package repositories or compatibility layers required for a seamless transition to newer software versions. This architectural limitation means that devices running these older firmware builds remain vulnerable indefinitely unless manually intervened upon, creating a persistent attack surface for organizations relying on this hardware. The inability to perform an in-place upgrade necessitates more disruptive maintenance procedures, increasing the operational burden and potential downtime during remediation efforts.

To mitigate these risks, it is imperative to update all affected devices to version 1.6.0 or later as soon as possible. This updated release addresses the authentication flaw by ensuring that any device without an existing administrator account will refuse API requests until a new owner creates one through the first-run wizard process. Furthermore, every route within the application programming interface is now restricted based on authenticated roles, enforcing strict access controls and preventing unauthenticated interaction with critical system functions. For devices running versions before 1.2.0 that cannot be upgraded in place due to their Debian 10 foundation, administrators must re-flash the device entirely using the 1.6.0 system image. This complete replacement of the firmware ensures both the resolution of the authentication vulnerability and the transition away from unsupported operating systems, thereby restoring security posture and maintaining long-term supportability aligned with current industry standards for secure embedded systems deployment.

Responsible

CERT-PL

Reservation

08/20/2026

Disclosure

10/26/2026

Moderation

accepted

EPSS

0.00000

KEV

no

Activities

very low

Sources

Want to stay up to date on a daily basis?

Enable the mail alert feature now!