EasyCorp EasyAdmin bis 4.8.9 Autocomplete autocomplete.js item Cross Site Scripting

CVSS Meta Temp ScoreAktueller Exploitpreis (≈)CTI Interest Score
3.4$0-$5k0.03

In EasyCorp EasyAdmin bis 4.8.9 wurde eine problematische Schwachstelle ausgemacht. Dabei geht es um die Funktion Autocomplete der Datei assets/js/autocomplete.js der Komponente Autocomplete. Durch die Manipulation des Arguments item mit einer unbekannten Eingabe kann eine Cross Site Scripting-Schwachstelle ausgenutzt werden. CWE definiert das Problem als CWE-79. Auswirkungen hat dies auf die Integrität.

Bereitgestellt wird das Advisory unter github.com. Die Verwundbarkeit wird als CVE-2024-3081 geführt. Die Ausnutzbarkeit gilt als leicht. Der Angriff kann über das Netzwerk angegangen werden. Eine Ausnutzung erfordert, dass das Opfer eine spezifische Handlung durchführt. Technische Details sind bekannt, ein verfügbarer Exploit hingegen nicht. Als Angriffstechnik weist das MITRE ATT&CK Projekt die ID T1059.007 aus.

Ein Aktualisieren auf die Version 4.8.10 vermag dieses Problem zu lösen. Eine neue Version kann von github.com bezogen werden. Die Schwachstelle lässt sich auch durch das Einspielen des Patches 127436e4c3f56276d548070f99e61b7234200a11 lösen. Dieser kann von github.com bezogen werden. Als bestmögliche Massnahme wird das Upgrade auf eine neue Version empfohlen. Das Advisory stellt fest:

XSS in autocomplete

Similar to https://github.com/EasyCorp/EasyAdminBundle/pull/5971

Die Schwachstellen VDB-1254 und VDB-8627 sind ähnlich.

Produktinfo

Hersteller

Name

Version

Lizenz

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔒
VulDB CVSS-BT Score: 🔒
VulDB Vector: 🔒
VulDB Zuverlässigkeit: 🔍

CVSSv3info

VulDB Meta Base Score: 3.5
VulDB Meta Temp Score: 3.4

VulDB Base Score: 3.5
VulDB Temp Score: 3.4
VulDB Vector: 🔒
VulDB Zuverlässigkeit: 🔍

CNA Base Score: 3.5
CNA Vector (VulDB): 🔒

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VektorKomplexitätAuthentisierungVertraulichkeitIntegritätVerfügbarkeit
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten

VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Zuverlässigkeit: 🔍

NVD Base Score: 🔒

Exploitinginfo

Klasse: Cross Site Scripting
CWE: CWE-79 / CWE-74 / CWE-707
CAPEC: 🔒
ATT&CK: 🔒

Lokal: Nein
Remote: Ja

Verfügbarkeit: 🔒
Status: Nicht definiert

EPSS Score: 🔒
EPSS Percentile: 🔒

Preisentwicklung: 🔍
Aktuelle Preisschätzung: 🔒

0-Dayfreischaltenfreischaltenfreischaltenfreischalten
Heutefreischaltenfreischaltenfreischaltenfreischalten

Threat Intelligenceinfo

Interesse: 🔍
Aktive Akteure: 🔍
Aktive APT Gruppen: 🔍

Gegenmassnahmeninfo

Empfehlung: Upgrade
Status: 🔍

0-Day Time: 🔒

Upgrade: EasyAdmin 4.8.10
Patch: 127436e4c3f56276d548070f99e61b7234200a11

Timelineinfo

29.03.2024 Advisory veröffentlicht
29.03.2024 +0 Tage CVE zugewiesen
29.03.2024 +0 Tage VulDB Eintrag erstellt
07.05.2024 +39 Tage VulDB Eintrag letzte Aktualisierung

Quelleninfo

Advisory: 5971/6067
Status: Bestätigt
Bestätigung: 🔒

CVE: CVE-2024-3081 (🔒)
Siehe auch: 🔒

Eintraginfo

Erstellt: 29.03.2024 08:35
Aktualisierung: 07.05.2024 18:33
Anpassungen: 29.03.2024 08:35 (62), 07.05.2024 18:25 (2), 07.05.2024 18:33 (17)
Komplett: 🔍
Cache ID: 34:022:40

Diskussion

Bisher keine Kommentare. Sprachen: de + en.

Bitte loggen Sie sich ein, um kommentieren zu können.

Interested in the pricing of exploits?

See the underground prices here!