PostgreSQL hasta 9.0.18/9.1.14/9.2.9/9.3.5/9.4.0 to_char desbordamiento de búfer

CVSS Meta puntuación temporalExploit Precio Actual (≈)Puntaje de interés de CTI
7.1$0-$5k0.00

Una vulnerabilidad clasificada como problemática fue encontrada en PostgreSQL hasta 9.0.18/9.1.14/9.2.9/9.3.5/9.4.0 (Database Software). La función to_char es afectada por esta vulnerabilidad. Mediante la manipulación de un input desconocido se causa una vulnerabilidad de clase desbordamiento de búfer. Esto tiene repercusión sobre la confidencialidad, integridad y disponibilidad.

La vulnerabilidad fue publicada el 2015-02-05 por Bruce Momjian con identificación News ID 1569 con un news (Website) (confirmado). El advisory puede ser descargado de postgresql.org. La vulnerabilidad es identificada como CVE-2015-0241. El ataque se puede hacer desde la red. Para explotarla se requiere una autentificación. Detalles técnicos son conocidos, pero no hay ningún exploit público disponible.

Para el scanner Nessus se dispone de un plugin ID 81193 (FreeBSD : PostgreSQL -- multiple buffer overflows and memory issues (3b40bf2c-ad83-11e4-a2b2-0026551a22dc)), que puede ayudar a determinar la existencia del riesgo analizado.

Una actualización a la versión 9.0.19, 9.1.15, 9.2.10, 9.3.6 o 9.4.1 elimina esta vulnerabilidad.

La vulnerabilidad también está documentado en las bases de datos X-Force (100777) y Tenable (81193).

Productoinfo

Escribe

Nombre

Versión

Licencia

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Confiabilidad: 🔍

CVSSv3info

VulDB Puntaje metabásico: 7.5
VulDB Meta puntuación temporal: 7.1

VulDB Puntuación base: 6.3
VulDB Puntuación temporal: 5.5
VulDB Vector: 🔍
VulDB Confiabilidad: 🔍

NVD Puntuación base: 8.8
NVD Vector: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplejidadAutenticaciónConfidencialidadIntegridadDisponibilidad
desbloqueardesbloqueardesbloqueardesbloqueardesbloqueardesbloquear
desbloqueardesbloqueardesbloqueardesbloqueardesbloqueardesbloquear
desbloqueardesbloqueardesbloqueardesbloqueardesbloqueardesbloquear

VulDB Puntuación base: 🔍
VulDB Puntuación temporal: 🔍
VulDB Confiabilidad: 🔍

NVD Puntuación base: 🔍

Explotacióninfo

Clase: Desbordamiento de búfer
CWE: CWE-119
CAPEC: 🔍
ATT&CK: 🔍

Local: No
Remoto: Sí

Disponibilidad: 🔍
Estado: No probado

EPSS Score: 🔍
EPSS Percentile: 🔍

Predicción de precios: 🔍
Estimación del precio actual: 🔍

0-Daydesbloqueardesbloqueardesbloqueardesbloquear
Hoydesbloqueardesbloqueardesbloqueardesbloquear

Nessus ID: 81193
Nessus Nombre: FreeBSD : PostgreSQL -- multiple buffer overflows and memory issues (3b40bf2c-ad83-11e4-a2b2-0026551a22dc)
Nessus File: 🔍
Nessus Riesgo: 🔍
Nessus Family: 🔍

OpenVAS ID: 14611
OpenVAS Nombre: Amazon Linux Local Check: ALAS-2015-503
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Nombre: 🔍

Inteligencia de Amenazasinfo

Interesar: 🔍
Actores Activos: 🔍
Grupos APT activos: 🔍

Contramedidasinfo

Recomendación: Upgrade
Estado: 🔍

Hora de 0 días: 🔍

Upgrade: PostgreSQL 9.0.19/9.1.15/9.2.10/9.3.6/9.4.1

Línea de tiempoinfo

2014-11-18 🔍
2015-02-05 +79 días 🔍
2015-02-05 +0 días 🔍
2015-02-11 +6 días 🔍
2015-02-11 +0 días 🔍
2015-09-16 +217 días 🔍
2015-09-17 +1 días 🔍
2022-03-09 +2365 días 🔍

Fuentesinfo

Producto: postgresql.org

Advisory: News ID 1569
Investigador: Bruce Momjian
Estado: Confirmado

CVE: CVE-2015-0241 (🔍)
OVAL: 🔍

X-Force: 100777 - PostgreSQL to_char buffer overflow, Medium Risk
SecurityTracker: 1031742
Vulnerability Center: 52641 - PostgreSQL Remote Code Execution due to Processing a Crafted Timestamp Formatting Template, Medium
SecurityFocus: 72540 - PostgreSQL 'to_char()' Function Buffer Overflow Vulnerability

Artículoinfo

Fecha de creación: 2015-02-11 09:05
Actualizaciones: 2022-03-09 02:26
Cambios: 2015-02-11 09:05 (67), 2017-12-23 13:14 (8), 2022-03-09 02:11 (2), 2022-03-09 02:19 (18), 2022-03-09 02:26 (1)
Completo: 🔍
Cache ID: 44:DAE:40

Discusión

Sin comentarios aún. Idiomas: es + en.

Por favor inicie sesión para comentar.

Are you interested in using VulDB?

Download the whitepaper to learn more about our service!