Nextcloud App up to 3.19.0 on Android improper authentication

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
3.0$0-$5k0.00

A vulnerability, which was classified as problematic, has been found in Nextcloud App up to 3.19.0 on Android (Android App Software). Affected by this issue is an unknown part. The manipulation with an unknown input leads to a improper authentication vulnerability. Using CWE to declare the problem leads to CWE-287. When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct. Impacted is confidentiality, integrity, and availability.

The weakness was shared 04/28/2022 as GHSA-32j4-9xf3-h2mg. The advisory is available at github.com. This vulnerability is handled as CVE-2022-24885 since 02/10/2022. The technical details are unknown and an exploit is not available.

Upgrading to version 3.19.1 eliminates this vulnerability. Applying a patch is able to eliminate this problem. The bugfix is ready for download at github.com. The best possible mitigation is suggested to be upgrading to the latest version.

The entries VDB-220816, VDB-220817, VDB-224661 and VDB-224662 are related to this item.

Productinfo

Type

Vendor

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 3.1
VulDB Meta Temp Score: 3.0

VulDB Base Score: 4.1
VulDB Temp Score: 3.9
VulDB Vector: 🔍
VulDB Reliability: 🔍

CNA Base Score: 2.0
CNA Vector (GitHub, Inc.): 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

Exploitinginfo

Class: Improper authentication
CWE: CWE-287
CAPEC: 🔍
ATT&CK: 🔍

Local: Yes
Remote: No

Availability: 🔍
Status: Not defined

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: App 3.19.1
Patch: github.com

Timelineinfo

02/10/2022 🔍
04/28/2022 +76 days 🔍
04/28/2022 +0 days 🔍
04/30/2022 +2 days 🔍

Sourcesinfo

Advisory: GHSA-32j4-9xf3-h2mg
Status: Confirmed

CVE: CVE-2022-24885 (🔍)
scip Labs: https://www.scip.ch/en/?labs.20130704
See also: 🔍

Entryinfo

Created: 04/28/2022 10:18 AM
Updated: 04/30/2022 11:48 AM
Changes: 04/28/2022 10:18 AM (52), 04/30/2022 11:48 AM (1)
Complete: 🔍
Cache ID: 44:D31:40

Discussion

No comments yet. Languages: en.

Please log in to comment.

Interested in the pricing of exploits?

See the underground prices here!