Moodle up to 2.1.2 Subsystem missing encryption

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
5.1$0-$5k0.00

A vulnerability was found in Moodle (Learning Management Software) and classified as problematic. This issue affects an unknown functionality of the component Subsystem. The manipulation with an unknown input leads to a missing encryption vulnerability. Using CWE to declare the problem leads to CWE-311. The product does not encrypt sensitive or critical information before storage or transmission. Impacted is integrity. The summary by CVE is:

CRLF injection vulnerability in calendar/set.php in the Calendar subsystem in Moodle 1.9.x before 1.9.15, 2.0.x before 2.0.6, and 2.1.x before 2.1.3 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via unspecified vectors.

The weakness was shared 07/20/2012 by Ryan Smith (Patrick) as confirmed git commit (GIT Repository). The advisory is shared at git.moodle.org. The identification of this vulnerability is CVE-2011-4586 since 11/29/2011. The exploitation is known to be easy. The attack may be initiated remotely. No form of authentication is needed for a successful exploitation. Neither technical details nor an exploit are publicly available. MITRE ATT&CK project uses the attack technique T1600 for this issue.

The vulnerability scanner Nessus provides a plugin with the ID 58172 (Debian DSA-2421-1 : moodle - several vulnerabilities), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Debian Local Security Checks.

Upgrading to version 1.9.3 eliminates this vulnerability. Applying a patch is able to eliminate this problem. The bugfix is ready for download at git.moodle.org. The best possible mitigation is suggested to be patching the affected component.

The vulnerability is also documented in the vulnerability database at Tenable (58172). The entries 61356, 61351, 61350 and 61348 are related to this item.

Productinfo

Type

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv3info

VulDB Meta Base Score: 5.3
VulDB Meta Temp Score: 5.1

VulDB Base Score: 5.3
VulDB Temp Score: 5.1
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Missing encryption
CWE: CWE-311 / CWE-310
ATT&CK: T1600

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 58172
Nessus Name: Debian DSA-2421-1 : moodle - several vulnerabilities
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍

OpenVAS ID: 71149
OpenVAS Name: Debian Security Advisory DSA 2421-1 (moodle)
OpenVAS File: 🔍
OpenVAS Family: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Patch
Status: 🔍

0-Day Time: 🔍

Upgrade: Moodle 1.9.3
Patch: 581e8dba387f090d89382115fd850d8b44351526

Timelineinfo

11/29/2011 🔍
12/06/2011 +7 days 🔍
01/02/2012 +27 days 🔍
07/20/2012 +200 days 🔍
07/20/2012 +0 days 🔍
07/22/2012 +2 days 🔍
03/23/2015 +974 days 🔍
12/06/2021 +2450 days 🔍

Sourcesinfo

Product: moodle.org

Advisory: DSA-2421
Researcher: Ryan Smith (Patrick)
Status: Confirmed
Confirmation: 🔍

CVE: CVE-2011-4586 (🔍)
OVAL: 🔍

Vulnerability Center: 35607 - Calendar Subsystem in Moodle Allows Remote CRLF Injection via Unspecified Vectors, Medium
SecurityFocus: 50923 - Moodle Multiple Security Vulnerabilities

See also: 🔍

Entryinfo

Created: 03/23/2015 04:50 PM
Updated: 12/06/2021 02:28 PM
Changes: 03/23/2015 04:50 PM (60), 04/14/2017 02:34 PM (13), 12/06/2021 02:23 PM (4), 12/06/2021 02:25 PM (1), 12/06/2021 02:28 PM (2)
Complete: 🔍

Discussion

No comments yet. Languages: en.

Please log in to comment.

Do you want to use VulDB in your project?

Use the official API to access entries easily!