Novell GroupWise 2012/8.0/8.00/8.01/8.02 Internet Agent numeric error

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
8.7$0-$5k0.00

A vulnerability, which was classified as critical, was found in Novell GroupWise 2012/8.0/8.00/8.01/8.02 (Groupware Software). Affected is an unknown code block of the component Internet Agent. The manipulation with an unknown input leads to a numeric error vulnerability. CWE is classifying the issue as CWE-189. This is going to have an impact on confidentiality, integrity, and availability. CVE summarizes:

Integer overflow in GroupWise Internet Agent (GWIA) in Novell GroupWise 8.0 before Support Pack 3 and 2012 before Support Pack 1 allows remote attackers to execute arbitrary code via unspecified vectors.

The weakness was shared 09/21/2012 by Francis Provencher (TippingPoint) with Zero Day Initiative (ZDI) (Website). The advisory is shared for download at novell.com. The vendor cooperated in the coordination of the public release. This vulnerability is traded as CVE-2012-0417 since 01/09/2012. The exploitability is told to be easy. It is possible to launch the attack remotely. The exploitation doesn't require any form of authentication. Technical details are unknown but a private exploit is available.

The vulnerability scanner Nessus provides a plugin with the ID 62284 (Novell GroupWise Internet Agent 8.x < 8.0.3 / 12.x < 12.0.1 Multiple Vulnerabilities), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Windows. The commercial vulnerability scanner Qualys is able to test this issue with plugin 121206 (Novell GroupWise Internet Agent Multiple Vulnerabilities).

Upgrading to version 8.xSP3 or 2012SP1 eliminates this vulnerability. The upgrade is hosted for download at download.novell.com. A possible mitigation has been published even before and not after the disclosure of the vulnerability. Furthermore it is possible to detect and prevent this kind of attack with TippingPoint and the filter 12495.

The vulnerability is also documented in the vulnerability database at Tenable (62284). The entries 6561, 6562, 6563 and 62332 are related to this item.

Productinfo

Type

Vendor

Name

Version

License

Support

  • end of life

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 10.0
VulDB Meta Temp Score: 8.7

VulDB Base Score: 10.0
VulDB Temp Score: 8.7
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Numeric error
CWE: CWE-189
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Access: Private
Status: Proof-of-Concept
Download: 🔍

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 62284
Nessus Name: Novell GroupWise Internet Agent 8.x < 8.0.3 / 12.x < 12.0.1 Multiple Vulnerabilities
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Exploit-DB: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: GroupWise 8.xSP3/2012SP1
TippingPoint: 🔍

Timelineinfo

01/09/2012 🔍
09/11/2012 +246 days 🔍
09/21/2012 +10 days 🔍
09/28/2012 +7 days 🔍
09/28/2012 +0 days 🔍
09/28/2012 +0 days 🔍
09/29/2012 +1 days 🔍
10/01/2012 +2 days 🔍
10/02/2012 +1 days 🔍
10/04/2012 +2 days 🔍
04/14/2021 +3114 days 🔍

Sourcesinfo

Vendor: novell.com

Advisory: novell.com
Researcher: Francis Provencher (TippingPoint)
Organization: Zero Day Initiative (ZDI)
Status: Confirmed
Confirmation: 🔍
Coordinated: 🔍

CVE: CVE-2012-0417 (🔍)
SecurityTracker: 1027599 - Novell GroupWise Internet Agent Integer Overflow Lets Remote Users Execute Arbitrary Code
Vulnerability Center: 36358 - Novell GroupWise <8.0 SP3 and < 2012 SP1 GWIA Allows Remote Code Execution, High
SecurityFocus: 55731 - Novell GroupWise Internet Agent CVE-2012-0417 Remote Integer Overflow Vulnerability
OSVDB: 85803

See also: 🔍

Entryinfo

Created: 10/01/2012 04:23 PM
Updated: 04/14/2021 02:26 PM
Changes: 10/01/2012 04:23 PM (79), 04/17/2017 11:51 AM (7), 04/14/2021 02:26 PM (3)
Complete: 🔍
Committer: roga

Discussion

No comments yet. Languages: en.

Please log in to comment.

Do you know our Splunk app?

Download it now for free!